Closed Bug 1693561 Opened 10 months ago Closed 10 months ago

profiles.ini is stat'ed twice in a row during early startup

Categories

(Toolkit :: Startup and Profile System, defect)

defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- fixed

People

(Reporter: florian, Assigned: florian)

References

(Regression)

Details

(Keywords: main-thread-io, regression, Whiteboard: [fxperf])

Attachments

(1 file)

Running browser_startup_mainthreadio.js locally reports this, but it doesn't happen when running in CI because the profiles.ini file doesn't exist on our test machines.

Here's a profile of running the test on my local Windows machine: https://share.firefox.dev/3udUnlk

Pushed by fqueze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb6cddd372c2
avoid stat'ing profiles.ini twice during startup, r=mossop.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
You need to log in before you can comment on or make changes to this bug.