Mozilla crashed when an app tried to open too many panels. When I restarted it, my MAIL was corrupted

RESOLVED DUPLICATE of bug 155080

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 155080
15 years ago
9 years ago

People

(Reporter: W. L. Stunkel, Assigned: Bienvenu)

Tracking

Trunk
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: OpenVMS Mozilla CPQ-AXPVMS-MOZILLA-M0101--1.PCSI

I had the MAIL panel open in the background. At some point, I opened a Browzer
panel that caused (briefly) my entire Motif session to hang. After a moment,
Mozilla crashed and disappeared from the desktop. When I restarted it, It asked
me to create a new mail profile. After a little fiddling, I found that if I
changes a directory of the form [WERNER._mozilla] "mumble"_SLT.DIR to an
equivalent name I found imbedded in the file [_mozilla]ivg52v0h_slt.dir, I had
access to my old desktop, bookmarks, address book, and even the root of all my
mail directories (it was managing about 4). However, the mail directories
presented on the mail panel are all blank even though the files of the form
"DISK$USER:[WERNER._mozilla.Werner.ivg52v0h.slt.MAIL.MAIL_ATTBI-1_COM]inbox."
contained the formerly available mail information.

I would like to be able to have MAIL repopulate it's directories with mail which
is already there right now. I would very much prefer not to lose that mail.

Reproducible: Always

Steps to Reproduce:
1.As I indicated above, the app has to crash before this happens.
2.Something similar happened on my MAC recently and I lost most of my mail.
3.

Actual Results:  
Finally got a machine where I could write to you. Now desparately awaiting your
resolution.

Expected Results:  
Protected all the mail. At least, a program should have been provided to
unscramble this mess.
(Assignee)

Comment 1

15 years ago
I believe this is a dup of the horrible prefs lost bug. Your prefs were
corrupted, so we lost track of where your mail is, because that's stored in prefs.

To fix this, you need to go into Edit | mail&newsgroups account settings and set
the local directory setting for your pop3 mail server (select the Server
Settings line for your pop3 server, and edit the path in the lower right hand
corner of the window to point to your old mail files)

*** This bug has been marked as a duplicate of 155080 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: gayatri → esther
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.