Last Comment Bug 169361 - flash player hangs mozilla 1.1
: flash player hangs mozilla 1.1
Status: VERIFIED DUPLICATE of bug 58339
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: ---
Assigned To: rubydoo123
: shrirang khanzode
Mentors:
http://www.ynet.co.il
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 23:09 PDT by ittay freiman
Modified: 2002-09-19 15:14 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description ittay freiman 2002-09-17 23:09:51 PDT
User-Agent:       Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827
Build Identifier: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

'strace mozilla www.ynet.co.il' gives me:
	write(5, "(\0Transferring data from www.yne"..., 2040) = 2040
	ioctl(5, 0x541b, [160])                 = 0
	read(5, "\17\245\321\v5\0\0\4\1\0\0\0\20\374\26\0008\374r\t\4\0"..., 		160) = 160
	poll([{fd=5, events=POLLIN, revents=POLLIN}, {fd=11, events=POLLIN}], 2, 0) = 1
	ioctl(5, 0x541b, [448])                 = 0
	read(5, "\7\1\237\f\10\235r[>\0\0\0\"\0\0\4#\0\0\4/\2\336\1+\2\310"..., 448) = 448
	gettimeofday({1032326389, 7143}, NULL)  = 0
	access("/tmp/.esd/socket", R_OK|W_OK)   = 0
	socket(PF_UNIX, SOCK_STREAM, 0)         = 33
	fcntl64(33, F_SETFD, FD_CLOEXEC)        = 0
	setsockopt(33, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
	connect(33, {sin_family=AF_UNIX, path="/tmp/.esd/socket"}, 18) = -1
ECONNREFUSED (Connection refused)
	socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 34
	fcntl64(34, F_SETFD, FD_CLOEXEC)        = 0
	setsockopt(34, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
	connect(34, {sin_family=AF_INET, sin_port=htons(16001), 	
sin_addr=inet_addr("0.0.0.0")}}, 16) = -1 ECONNREFUSED (Connection refused)
	open("/usr/etc/esd.conf", O_RDONLY)     = -1 ENOENT (No such file or directory)
	open("/home/ittay/.esd.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
	access("/dev/dsp", W_OK)                = 0
	open("/dev/dsp", O_WRONLY


then mozilla hangs. 

i am using redhat 7.3, with kde 3.0 and my sound card is an ac97 onboard by via.

i've read on some news group that changing /dev/dsp to /dev/dsp1 in
libflashplayer.so solves the problem. however, when i tried that i got a
segmantation fault.

Reproducible: Always

Steps to Reproduce:
1. use a redhat 7.3, kde 3.0
2. install the latest flash player plugin (5.05r1 i think)
3. go to a site with flash (and sound?)

Actual Results:  
mozilla hangs, even before showing some of the sites contents

Expected Results:  
dah...
Comment 1 R.K.Aa. 2002-09-17 23:28:11 PDT
Duplicate number 94 of bug 58339. Try starting mozilla with "artsdsp mozilla"

*** This bug has been marked as a duplicate of 58339 ***
Comment 2 shrirang khanzode 2002-09-19 15:14:27 PDT
v

Note You need to log in before you can comment on or make changes to this bug.