Closed Bug 1693670 Opened 7 months ago Closed 7 months ago

Exceptions in CardDAV sync operations shouldn't prevent the next sync

Categories

(MailNews Core :: Address Book, defect)

defect

Tracking

(thunderbird_esr78 fixed)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

Details

Attachments

(1 file)

Currently if an exception is thrown during syncing, the next sync isn't scheduled. We could probably also handle exceptions better (like providing some user feedback) but for now I'm just going to put a try/finally block around the sync operations.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/3b7f3fbc2201
Do CardDAV sync in a try/finally block so the next sync is always scheduled. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Uplift or not?

Comment on attachment 9204078 [details]
Bug 1693670 - Do CardDAV sync in a try/finally block so the next sync is always scheduled. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: carddav sync errors cause it to stop syncing for the rest of the session
Testing completed (on c-c, etc.): in 87 beta
Risk to taking this patch (and alternatives if risky): no risk

Attachment #9204078 - Flags: approval-comm-esr78?

Comment on attachment 9204078 [details]
Bug 1693670 - Do CardDAV sync in a try/finally block so the next sync is always scheduled. r?mkmelin

[Triage Comment]
Approved for esr78

Attachment #9204078 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.