Use nsITheme with HTML form controls

RESOLVED FIXED

Status

()

RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: hyatt, Assigned: hyatt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

17 years ago
The following bug is to track implementing support for nsITHeme in the current 
set of form controls.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

17 years ago
Created attachment 99632 [details]
Test file.
(Assignee)

Comment 2

17 years ago
Created attachment 99633 [details] [diff] [review]
Work in progress.  3/4 of the way there on Win32 or so.  Just three widgets left.

Just tracking my work so I don't lose it.
(Assignee)

Comment 3

17 years ago
Created attachment 99911 [details]
Test file that shows all widgets

This test file shows all the form controls.  You can load it in WinIE and in
Gecko to compare.
(Assignee)

Updated

17 years ago
Attachment #99632 - Attachment is obsolete: true
Attachment #99633 - Attachment is obsolete: true
(Assignee)

Comment 4

17 years ago
Created attachment 99913 [details] [diff] [review]
The patch.  Handles all form controls under WinXP.
(Assignee)

Comment 5

17 years ago
I am ready for r/sr.

Comment 6

17 years ago
Comment on attachment 99913 [details] [diff] [review]
The patch.  Handles all form controls under WinXP.

Two thumbs up.	If you apply just one patch this year, apply this one.
Attachment #99913 - Flags: review+

Comment 7

17 years ago
Comment on attachment 99913 [details] [diff] [review]
The patch.  Handles all form controls under WinXP.

sr=hewitt
Attachment #99913 - Flags: superreview+
(Assignee)

Comment 8

17 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 149078 has been marked as a duplicate of this bug. ***
*** Bug 149709 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
What about Linux? Is there a bug filed for that?
You need to log in before you can comment on or make changes to this bug.