Closed Bug 1693962 Opened 1 year ago Closed 1 year ago

Remove use of widgetglue.js from SeaMonkey's mailnews code

Categories

(SeaMonkey :: MailNews: General, task)

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.85
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.8)

Attachments

(1 file)

This ports the changes from TB for:

  • Bug 889022 - Remove mail/base/content/widgetglue.js

which landed in TB 26.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.7
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9204369 - Flags: review?(frgrahl)
Attachment #9204369 - Flags: approval-comm-release?
Attachment #9204369 - Flags: approval-comm-esr60?
Blocks: 1694760

Comment on attachment 9204369 [details] [diff] [review]
1693962-remove-widegetglue-2538.patch

LGTM. In the unlikely even that add-ons are affected we might have to add only widgetglue.js back to 2.53 only.

Attachment #9204369 - Flags: review?(frgrahl)
Attachment #9204369 - Flags: review+
Attachment #9204369 - Flags: approval-comm-release?
Attachment #9204369 - Flags: approval-comm-release+
Attachment #9204369 - Flags: approval-comm-esr60?
Attachment #9204369 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c89cbf5c4eca
Remove use of widgetglue.js from SeaMonkey's mailnews code. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.85
You need to log in before you can comment on or make changes to this bug.