Closed Bug 1693977 Opened 1 year ago Closed 1 year ago

MP4v2 (ISO 14496-14) MP3 audio missing

Categories

(Core :: Audio/Video: Playback, defect, P3)

78 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: armin, Assigned: jbauman)

References

Details

(Whiteboard: [media-audio])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

I have a videofile, encoded with x264 and MP3 audio. I put the same streams once in a MP4v1 (IS0 14496-12:2003) and once in a MP4v2 (ISO 14496-14) container. Here is the output of the "file" command:
VIDEOv1.mp4: ISO Media, MP4 Base Media v1 [IS0 14496-12:2003]
VIDEOv2.mp4: ISO Media, MP4 v2 [ISO 14496-14]
I'm currently using FF 78.7.0esr (64-bit)

Actual results:

When opening the file directly (using file://), the video was displayed properly. But the audio was only available on the MP4v1 container. In the MP4v2 container, the video kept silent (of course I verified, there was no mute setting). In the tab, the "sound icon" was also only visible with the MP4v1 version.

Expected results:

The audio should be played with both versions. Since I created both files from the same source and I only copied the streams, I am sure the streams themselves are correct.

The Bugbug bot thinks this bug should belong to the 'Core::Audio/Video: Playback' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Attached video VIDEOv1.mp4

This is a simple example video. This version is working as expected.

Attached video VIDEOv2.mp4

This is the same audio and video as VIDEOv1.mp4, but there is no audio output in Firefox.

I suspect an mp4parse issue, but requires further investigation.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [media-audio]

Dumping the two videos with https://gpac.github.io/mp4box.js/test/filereader.html shows VIDEOv1 uses mp4a.6b for audio and VIDEOv2 uses mp4a.69. We just recently added support for 0x69 to the parser, but that hasn't been merged into Firefox yet. I've confirmed with local testing that change will fix this when it lands.

Depends on: 1696780
Assignee: nobody → jbauman
Status: NEW → ASSIGNED

Now that bug 1696780 has merged, including the update from mp4parse-rust, this should be resolved.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.