If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clicking the dock icon should always result in a window

VERIFIED DUPLICATE of bug 90823

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 90823
15 years ago
15 years ago

People

(Reporter: Benedikt Roth, Assigned: joki (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
As described in
http://developer.apple.com/techpubs/macosx/Essentials/AquaHIGuidelines/AHIGDock/index.html
clicking a dock icon should always result in a new window.
This is currrently not the case and is IMHO a quite disturbing behaviour.

Comment 1

15 years ago
*** Bug 169511 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Invalid. That isn't what the HIGs say at all. To quote from the URL you provided:

"Clicking an application icon in the Dock should always result in a window—a
document or another appropriate window—becoming active. In a document-based
application that is not open when the user clicks the Dock icon, the application
should open a new, untitled window."

"...When a user clicks an open application's icon in the Dock, the application
becomes active and all open unminimized windows are brought to the front;
minimized document windows remain in the Dock. If there are no unminimized
windows when the user clicks the Dock icon, the last minimized window should be
expanded and made active. If no documents are open, the application should open
a new window. (If your application is not document based, display the
application's main window.)"

Now, there are some problems with other aspects of those paragraphs, but
clicking the application's dock icon should clearly *not* always result in a new
window.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Summary: Clicking the dock icon should always reslut in a window → Clicking the dock icon should always result in a new window
(Reporter)

Comment 3

15 years ago
Yes, you are right. My mistake. I didn't mean 'new window' but just 'window'.
And if I've looked correclty I would have noticed that such a bug is already
filed as #90823 .
But apparently I'm too confused, dumb or both to even file this (wrong
described) bug just once.
Sorry.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 90823 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Summary: Clicking the dock icon should always result in a new window → Clicking the dock icon should always result in a window

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 5

15 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.