Closed Bug 1695592 Opened 2 years ago Closed 2 years ago

Moving a Contact from one Carddav Addressbook to another prevents the synchronization

Categories

(MailNews Core :: Address Book, defect)

Thunderbird 87
defect

Tracking

(thunderbird_esr78 fixed, thunderbird89 fixed)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird89 --- fixed

People

(Reporter: cn, Assigned: darktrojan)

Details

Attachments

(3 files)

Attached file TB_Carddav_move.txt

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:85.0) Gecko/20100101 Firefox/85.0

Steps to reproduce:

Subscribe to two Carddav adress books in Beta 87. Drag and Drop one contact from one address book to the other.

Actual results:

The contact is moved on the Thunderbird side but not synced to the new address book on the server. It is deleted in the old address book on both server and Thudnerbird.

Expected results:

The contact should be moved and synced to the server. The problem is that Thunderbird is using the URL (C4849D44-FB00-0001-BB82-1F9E1DA912C5) associated with the "origin" address book not the one of the target address book (902-5FD1CA80-129-5915DC00) (see attached file)

Thanks for the report, and for figuring out the problem. It should be simple to fix.

Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Component: Untriaged → Address Book
Ever confirmed: true
Product: Thunderbird → MailNews Core

The _etag and _href properties only make sense in the context of a card's original directory. Remove them when moving or copying a card to another directory.

Also if we change the card's UID when copying it, make sure the stored vCard has the updated UID too.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/7ccaa9ec02a7
Don't copy CardDAV-specific properties to another directory. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9217676 [details]
Bug 1695592 - Don't copy CardDAV-specific properties to another directory. r?mkmelin

[Triage Comment]
Taking for 89.0b4.

Attachment #9217676 - Flags: approval-comm-beta+

[Approval Request Comment]
Regression caused by (bug #): Never worked
User impact if declined: Address book gets confused if moving contacts between directories
Testing completed (on c-c, etc.): In 89.0b4
Risk to taking this patch (and alternatives if risky): Small

Attachment #9223685 - Flags: approval-comm-esr78?

Comment on attachment 9223685 [details] [diff] [review]
1695592-esr78.diff

[Triage Comment]
Approved for esr78

Attachment #9223685 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.