Closed Bug 1695771 Opened 3 years ago Closed 3 years ago

Flashing green artificats on website including animated elements on Adreno 330

Categories

(Core :: Graphics: WebRender, defect)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: h.winnemoeller, Assigned: jnicol)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

WARNING RAPIDLY FLASHING IMAGES

Steps to reproduce

  1. Set gfx.webrender.all to true and restart Fenix
  2. Open any website with animated elements, e.g. https://github.com/mozilla-mobile/fenix/issues/2370

Expected results
Website is displayed normally.

Actual results
Website exhibits rapidly flashing green elements, see attached video (WARNING RAPIDLY FLASHING ELEMENTS).

Device Info
Vendor and Model: Sony Xperia Z2
OS version: Android 6.0.1
GPU model: Adreno 330 (WebRender Compositing)
Number of cores: 4 (Snapdragon 801)

Fenix version
Nightly 210301 12:11 (Build #2015796129)
AC: 74.0.20210227143138, 5437eb229
GV: 88.0a1-20210227094458
AS: 72.1.0

Blocks: wr-adreno3xx
Version: unspecified → Trunk

I wonder if this is due to a bug in the driver's partial present feature.

Henrik, could you try flipping gfx.webrender.allow-partial-present-buffer-age to false, restart (by swiping the app away in the app switcher) and see if that helps?

Flags: needinfo?(h.winnemoeller)

(In reply to Jamie Nicol [:jnicol] from comment #1)

Henrik, could you try flipping gfx.webrender.allow-partial-present-buffer-age to false, restart (by swiping the app away in the app switcher) and see if that helps?

That actually helps, I do not see the artifacts anymore. (But performance suffers noticeably when the animated GIFs come into view on https://github.com/mozilla-mobile/fenix/issues/2370.) Update: Nevermind, it also does not perform well with setting gfx.webrender.allow-partial-present-buffer-age to true.

Flags: needinfo?(h.winnemoeller)

But the flashing and green artefacts are completely gone? That's great news.

Would you mind filling a separate bug about the performance issue? And could you attach a profile using the "Firefox graphics" settings preset. Thanks!

(In reply to Jamie Nicol [:jnicol] from comment #3)

But the flashing and green artefacts are completely gone? That's great news.

Yes, it's completely gone. Even on YouTube until it resets due to Bug 1507074. I'm seeing new issues when accessing some articles on bbc.com, will report that in a new issue, see Bug 1695912.

Would you mind filling a separate bug about the performance issue? And could you attach a profile using the "Firefox graphics" settings preset. Thanks!

Sure, will do! Should I then set gfx.webrender.allow-partial-present-buffer-age to false? It does not seem to make a difference in this specific case but just asking since this might become the default setting for this architecture?

Flags: needinfo?(jnicol)

Yes, you might as well set and keep that as false, I will make that the default for Adreno 3xx. Thanks a lot for all the testing!

Flags: needinfo?(jnicol)

It is buggy and causes rendering issues.

Assignee: nobody → jnicol
Status: NEW → ASSIGNED
Pushed by jnicol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd4829a26c69
Disable partial present on Adreno 3xx GPUs. r=aosmond
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: