Closed Bug 1695869 Opened 2 months ago Closed 24 days ago

Favorite and recent folders do not show im in macOS menu since 2.53.6

Categories

(SeaMonkey :: MailNews: Backend, defect)

SeaMonkey 2.53 Branch
Unspecified
macOS
defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey2.53
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: bugzilla, Assigned: frg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.7)

Attachments

(2 files)

The folder list is empty, and we can't close the virtual folder edit popup and all the mail section is blocked !
We have to quit seamonkey!

+++ This bug was initially created as a clone of Bug #268061 +++
Folder selection dialog transparent and list empty when creating a new search (virtual) folder
When creating a new search folder with Modern theme the folder selection dialog
is transparent and the folder list is/looks empty. Works fine with the classic
theme. Using trunk build 2004-11-05 with WinXP @32-bit color depth. A screen
shot follows.

Severity: normal → S2

The File/Virtual Folder menu doesn't work either.

Summary: Cannot create or modify virtual folders since 2.53.6 or less → Cannot create or modify virtual folders since 2.53.6

The folder list is empty, and we can't close the virtual folder edit popup and all the mail section is blocked !
We have to quit seamonkey!

This is fixed in SeaMonkey 2.53.7b1. Should appear soon. Bug 1691208.

The recent and favorite folders still do not display in macOS but this is a different issue. I think Bug 546722 regressed this.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot create or modify virtual folders since 2.53.6 → Favorite and recent folders do not show im in macOS menu since 2.53.6

Not fixed in 2.53.7 and 2.538b1 pre yet

Timestamp: 25.03.21, 15:19:31 CET
Error: TypeError: menu.menupopup is undefined
Source File: chrome://messenger/content/folderWidgets.xml
Line: 704

Browser console:
TypeError: menu.menupopup is undefined[Learn More] folderWidgets.xml:704:13
_buildSpecialSubmenu chrome://messenger/content/folderWidgets.xml:704:13
_buildSpecialMenu/< chrome://messenger/content/folderWidgets.xml:624:40

Seems on mac the event listener fires before the popupmenu is attached as a child. Basically the current comm-central code also uses menupopup as a parameter for it to fix this.
[Approval Request Comment]
Regression caused by (bug #): Bug 809066
User impact if declined: no favorite or recent folder
Testing completed (on m-c, etc.): 2.53.8b1 pre Windows and macOS x64
Risk to taking this patch (and alternatives if risky): trivial change
String changes made by this patch: --

Assignee: nobody → frgrahl
Attachment #9211776 - Flags: review?(iann_bugzilla)
Attachment #9211776 - Flags: approval-comm-release?
Attachment #9211776 - Flags: approval-comm-esr60?
Status: NEW → ASSIGNED

Would be ok to take this to 2.53.7

Comment on attachment 9211776 [details] [diff] [review]
1695869-menupopup-2538.patch

[Triage Comment]
Good find, r/a=me

Attachment #9211776 - Flags: review?(iann_bugzilla)
Attachment #9211776 - Flags: review+
Attachment #9211776 - Flags: approval-comm-release?
Attachment #9211776 - Flags: approval-comm-release+
Attachment #9211776 - Flags: approval-comm-esr60?
Attachment #9211776 - Flags: approval-comm-esr60+

(In reply to Frank-Rainer Grahl (:frg) from comment #5)

Would be ok to take this to 2.53.7

Agreed.

https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/53feed7dc7ea9b341fed8ea8fd8c7c417ef8c7f5
Use popupmenu directly when building special menus. r=IanN a=IanN
Target 2.53.7 final

Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
Whiteboard: SM2.53.7
Target Milestone: --- → seamonkey2.53
You need to log in before you can comment on or make changes to this bug.