Closed Bug 1696175 Opened 2 months ago Closed 20 hours ago

Call DisconnectChildListeners at a later time for BFCache in the parent

Categories

(Core :: DOM: Navigation, task, P1)

task

Tracking

()

RESOLVED FIXED
90 Branch
Fission Milestone M7a
Tracking Status
firefox90 --- fixed

People

(Reporter: peterv, Assigned: peterv)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Currently we special-case DocumentChannelChild::RecvDisconnectChildListeners to always disconnect for top-level browsing contexts if BFCache in the parent is enabled. This is called when the promise created by DocumentLoadListener's OpenDocument is rejected, for example from DocumentLoadListener's DisconnectListeners because we're going to do a process switch. We want to move that to later in the loading, when we've actually done the remoteness switch.

I did a try run which should show some of the issues that come from disconnecting all BC's listeners where we currently do: https://treeherder.mozilla.org/jobs?repo=try&revision=9654f1251ae7a9314727de87caf3065257edae15

Fission Milestone: --- → M7a
Blocks: 1677324
Duplicate of this bug: 1689630
Severity: -- → S3
Priority: -- → P1
Attachment #9217434 - Attachment description: Bug 1696175 - Call DisconnectChildListeners at a later time for BFCache in the parent. r?smaug! → Bug 1696175 - Call DisconnectChildListeners at a later time for BFCache in the parent. r?nika!
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1107a30b3f7
Call DisconnectChildListeners at a later time for BFCache in the parent. r=necko-reviewers,nika
Status: ASSIGNED → RESOLVED
Closed: 20 hours ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.