Closed Bug 1696553 Opened 9 months ago Closed 8 months ago

[Proton] Tab load burst shows up outside of the tab shape

Categories

(Firefox :: Theme, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: [proton-tabs-bar][priority:2c] )

Attachments

(2 files, 1 obsolete file)

With the Proton tabs, when a tab has finished loading, the tab load burst shows up outside of the tab shape. The burst should be constrained to the tab pill shape.

Assignee: nobody → zbraniecki
Status: NEW → ASSIGNED
Attached image screenshot
Points: --- → 3
Priority: P3 → P2
Duplicate of this bug: 1696818
Assignee: zbraniecki → jaws
Attachment #9207587 - Attachment is obsolete: true
Whiteboard: [proton-tabs-bar] → [proton-tabs-bar][priority:2c]
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1558e615475
Move the loading burst inside of the tab-background so it will get clipped by the tab shape and border radius. r=desktop-theme-reviewers,ntim
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Hello! I can confirm that the issue is fixed using Firefox 89.0a1 (2021-04-06) on Windows 10, mamOS 10.15 and Ubuntu 20. I will update the flags accordingly.

Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.