Closed Bug 1696698 Opened 2 years ago Closed 2 years ago

Remove unnecessary and confusing reader.parse-on-load.force-enabled pref

Categories

(Toolkit :: Reader Mode, defect, P5)

Firefox 86
defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: steffen19w23, Assigned: samo.golez)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

In about:config set
reader.parse-on-load.force-enabled true

Actual results:

At most sites (e.g. https://bugzilla.mozilla.org) neither reader icon appears nor does F9 switch to reader mode.

Expected results:

At all sites the reader icon should appear and F9 switches to reader mode.

The Bugbug bot thinks this bug should belong to the 'Toolkit::Reader Mode' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

reader.parse-on-load.force-enabled does not force the Reader Mode button to be displayed. Instead, it ensures that the Readability library attempts to parse every page, regardless of whether the machine is considered "low memory". Interestingly, the low memory checks were removed in bug 1369327, so I don't think this pref has much value anymore.

I'm going to transmute the bug to remove the pref since it's purpose is pretty confusing.

Severity: -- → N/A
Priority: -- → P5
Summary: reader.parse-on-load.force-enabled has no effect → Remove unnecessary and confusing reader.parse-on-load.force-enabled pref
Assignee: nobody → samo.golez
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfe7593fcce2
Remove reader.parse-on-load.force-enabled pref. r=mconley
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
You need to log in before you can comment on or make changes to this bug.