document.body.clientHeight = 0 if no scrollbars=1 passed to window.open()

RESOLVED DUPLICATE of bug 180552

Status

()

RESOLVED DUPLICATE of bug 180552
16 years ago
6 years ago

People

(Reporter: markvds, Assigned: ashuk)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The value of document.body.clientHeight when used in a popup is always 0 if no
'scrollbars=1' is passed to the window.open() function. I tried it with Mozilla
1.1 and I just tried it with Mozilla 1.2a. Both got the same problem. I think
this is not how it should be.

Comment 1

16 years ago
Created attachment 109119 [details]
Testcase

WFM using build 2002120808, Windows 2000.

Reporter, can you attach a testcase showing the bug? If bug is gone, please
mark this one as WORKSFORME.

Updated

16 years ago
Component: Java APIs for DOM → DOM Mozilla Extensions

Comment 2

16 years ago
WFM also on XP with build 2002122608. Please reopen if you still see this, and
if yes, then please attach a testcase or url to illustrate the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
The problem still exists and I don't think it's the intended behaviour; why
should the document.body.clientHeight be 0 while the body contains content?

Testcase URL:
http://www.elegia.nl/bugzilla/opendoc.html

During my first submission I used Win98, now I used WinXP with build 2002121215
(Mozilla 1.3a)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 180552 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.