Will not open embeded link

RESOLVED DUPLICATE of bug 84128

Status

()

Core
Networking: File
--
major
RESOLVED DUPLICATE of bug 84128
15 years ago
14 years ago

People

(Reporter: Denis Van Dale, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
We have an internal web page for employee use.  There are serveral links that
can be opened only if you are logged in to the LAN.  The form of the link is as
follows

file:///f:/scu/manuals/index.htm

This should open a second page, but does not.  BTW Netscape 6.x and 7.x have the
same problem.  Netscape 4.x works as does IE. Strangely if I enter the link in
the url manually, it does open the second page.  The second page has several
links using the same format and these work OK.

We have an application that is web based called eCabinet from RIcoh that runs on
FreeBSD.  It has links that will not open using Mozilla or Netscape 6.x or 7.x
but work fine with IE and Netscape 4.7

Comment 1

15 years ago
WFM with 2002111817/1.2/win2k.

reporter (Denis): can you reproduce this bug with a recent build of mozilla (for
example, 1.2)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.

Comment 2

15 years ago
->Networking

Comment 3

15 years ago
really assigning.  sorry for the spam
Assignee: asa → dougt
Component: Browser-General → Networking: File
QA Contact: asa → benc

Comment 4

15 years ago
Is the URL of the page w/ the link http or https?

Comment 5

15 years ago
Denis: mozilla will not (by default) allow users to follow file:// URLs that are
in pages that came from a network server (like http: or https:).

Is this the case for you?

Comment 6

14 years ago
I have the same problem. I'm using a Java servlet to return HTML pages and one
of them has local file links. If I open the page as an HTML file, the links
work, but if the page is returned from a server, it doesn't do anything nor does
it show an error message (I thought it was a bug!!!).

I understand the security reasons to not let this local links work when they
come from a server, and I know it's better to write links to http URLs (the same
local files put in a public directory of a web server, for example), but:

1) An error message would be extremely useful to let the user know it is not a bug
2) I think this feature should be configurable (I don't know whether it is
already configurable, but I haven't found the option in the preferences)

Comment 7

14 years ago
RESOLVED/dupe:
The problem is that ALL file links are disabled on pages that came from a server
(http:, https: URLS).

http://www.mozilla.org/quality/networking/docs/netprefs.html#file

You can turn this feature off w/ about:config.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Will not open embeded link to a mapped networked drive → Will not open embeded link
You need to log in before you can comment on or make changes to this bug.