Closed Bug 1696845 Opened 2 years ago Closed 2 years ago

Use dlsym for gdk_*_display_get_type

Categories

(Core :: Widget: Gtk, task)

Desktop
Linux
task

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: heftig, Assigned: heftig)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Using dlsym for gdk_wayland_display_get_type is a cleaner solution to bug 1696319, allowing running with a GTK that lacks the Wayland backend.

Also adds a symmetric implementation for gdk_x11_display_get_type, which should help running without X11.

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a4f4f640eaa7
Use dlsym for gdk_*_display_get_type. r=stransky
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/988c04abcb91
Use dlsym for gdk_*_display_get_type. r=stransky
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Flags: needinfo?(jan.steffens)
Duplicate of this bug: 1614266
You need to log in before you can comment on or make changes to this bug.