The default bug view has changed. See this FAQ.

Restored window position and size lost after a full screen (linux)

RESOLVED DUPLICATE of bug 126730

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 126730
15 years ago
9 years ago

People

(Reporter: Erich 'Ricky' Iseli, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment 16 before commenting], URL)

Attachments

(2 obsolete attachments)

(Reporter)

Description

15 years ago
Tested on: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.1) Gecko/20020919

Steps to reproduce:
1) resize the window to anything smaller than the screen ("restored" state)
2) maximize the window
3) press F11 to get into full screen modus
4) press F11 again to quit full screen modus
=> Result: the window is now as big as in step 2, but in the "restored" state.
Initial size and position (step 1) are lost.
=> Expected result: window should be in the maximized state and should be
restorable to size and position in step 1.

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 1

15 years ago
This is a mozilla bug, not a phoenix bug. It's existed in Mozilla for as long as
full-screen has been around. Please do not file bugs on the Phoenix product for
issues that also exist in Mozilla. If it's something we decide to tackle
independently of Mozilla then we'll file the bug. Thanks.

Comment 2

15 years ago
Oops. This is something we decided to tackle independently of Mozilla.  It's #37
on our to-do list <http://mozilla.org/projects/phoenix/todo.html>. Sorry.
Reopening. 
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

15 years ago
OS: Linux → All
Target Milestone: --- → Phoenix0.2

Comment 3

15 years ago
-> hewitt
Assignee: blaker → hewitt
Status: REOPENED → NEW

Updated

15 years ago
Target Milestone: Phoenix0.2 → Phoenix0.3

Comment 4

15 years ago
I believe that this is also being tracked as Mozilla Browser bug 126730 so maybe
we'll get lucky and pick up a fix from them.

Updated

15 years ago
Target Milestone: Phoenix0.3 → Phoenix0.4

Comment 5

15 years ago
Patch checked into Mozilla and awaiting review.

Comment 6

15 years ago
When was a patch checked in into mozilla-code?
I saw only a suggested patch for windows in bug 126730
the author writes in http://bugzilla.mozilla.org/show_bug.cgi?id=126730#c31

> it's still incompleted, because the patch only fixed the problem on Windows. 
> I'll try to fix the *nix part in a near future.

There´s also bug 176640 which has a patch for linux, don´t know if it´s ready.

Updated

15 years ago
Target Milestone: Phoenix0.4 → Phoenix0.5

Updated

15 years ago
Target Milestone: Phoenix0.5 → Phoenix0.6

Comment 7

15 years ago
This now works as expected with RH8 and any window manager on linux for which
_NET_WM_STATE_FULLSCREEN is supported. Support for older window managers will be
addressed in bug 179043 (I suspect "full screen" will be not be implemented for
older window managers. See bug 179043 comment 11 ).
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 8

14 years ago
v.
Status: RESOLVED → VERIFIED

Comment 9

13 years ago
I'm wrong. This is not a linux specific problem and it's still a problem. All
recent Firefox builds on Windows and Linux have this problem. If you are in the
restored state (not maximized) with a window that, for example, takes up 1/4th
of your screen, and you hit F11 to go to fullscreen, and then hit f11 to get out
of fullscreen, you are returned to _a_ restored state but not _your_ restored
state. You get a nearly full screen sized restored window and your restored
information (size and position) are forever lost. This is ugly. 

Tested windows and linux branch 0.9 builds 2004071509. 
Status: VERIFIED → REOPENED
Flags: blocking-aviary1.0?
Resolution: FIXED → ---
Target Milestone: Firebird0.6 → ---

Updated

13 years ago
Assignee: hewitt → firefox
Status: REOPENED → NEW

Updated

13 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P4

Comment 10

13 years ago
(In reply to comment #0)
> Tested on: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.1) Gecko/20020919
> 
> Steps to reproduce:
> 1) resize the window to anything smaller than the screen ("restored" state)
> 2) maximize the window
> 3) press F11 to get into full screen modus
> 4) press F11 again to quit full screen modus
> => Result: the window is now as big as in step 2, but in the "restored" state.
> Initial size and position (step 1) are lost.
> => Expected result: window should be in the maximized state and should be
> restorable to size and position in step 1.

Discovered same Bug, well I think its the same bug anyway.

Step 4 was different. Intead of pressing F11 again I clicked the restore button
in fullscreen mode.
 => Result: the window is now in restored state not maximised like it should.
And its position and size have changed from that set in step 1 to mimic a
maximised window.
 => Expected: I would think the window should return to maximised. Or possibly
to restored state with the same size and position as set in step 1(although I
think returning to its last state which in this example is Maximised would be
more appropriate)

Comment 11

13 years ago
Linux and Windows fullscreen modes are different code, I believe. This was filed
on Linux so I'm resetting it to Linux. This should have been resolved fixed
after comment #7
Flags: blocking-aviary1.0+
OS: All → Linux

Comment 12

13 years ago
sorry for the spam but are all of these related in some way?
https://bugzilla.mozilla.org/show_bug.cgi?id=192000
https://bugzilla.mozilla.org/show_bug.cgi?id=221625
https://bugzilla.mozilla.org/show_bug.cgi?id=248473
https://bugzilla.mozilla.org/show_bug.cgi?id=249388

Comment 13

12 years ago
Created attachment 196380 [details]
Check out the print screen.  Why is the bottom of the page like this?

Do you have a fix for this?

Comment 14

11 years ago
Created attachment 206182 [details]
Screenshot

It appears that there is some confusion. I am sure this bug has nothing to do with switching back from full screen etc. This screenshot shows what the screen looked like immediately after installing the latest version (17 Dec 2005) of Firfox Deer Park Alpha 2. I have not done any resizing/full screen etc. Firefox comes up with a huge chunk of grey at the bottom of the screen with no way to get rid of it. It is a seriously irritating bug since you can not see part of the web page. The description of the fault on your todo list does not sound the same.

Comment 15

11 years ago
This bug appears to have been sidelined. It is a show-stopper. Please look at the attachments. One can't work like this. If there is a work around please post info ASAP. Needs urgent attention!

Updated

11 years ago
Attachment #196380 - Attachment is obsolete: true

Updated

11 years ago
Attachment #206182 - Attachment is obsolete: true

Comment 16

11 years ago
The screenshots that Dave and Matthew posted have nothing to do with this bug; they are due to extensions breaking chrome. 

Please do not comment here unless you are contributing to a solution. (Sorry for the bugspam.)
Assignee: firefox → nobody
Priority: P4 → --
QA Contact: asa → general
Whiteboard: [see comment 16 before commenting]
Version: unspecified → Trunk
Andrew, do you see this. See comment 11
Summary: Restored window position and size lost after a full screen → Restored window position and size lost after a full screen (linux)

Comment 18

9 years ago
only with a branch build.  this was fixed recently
Status: NEW → RESOLVED
Last Resolved: 15 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 126730
You need to log in before you can comment on or make changes to this bug.