Closed Bug 1697631 Opened 7 months ago Closed 6 months ago

Fission + sw-wr: TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/minimize_window/minimize.py | expected OK

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M7a
Tracking Status
firefox88 --- affected

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug)

Details

In bug 1697195, we tried to auto-enable SW-WR with Fission is enabled. Unfortunately, some tests failed when run with Fission + SW-WR mode:

webdriver failures:

https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&searchStr=wd&revision=d5ebf7eedb59abee4bc6c5750543917fa4ff8a6d&selectedTaskRun=EKW2XgDxRS6J0qBBL5YOiw.0

https://treeherder.mozilla.org/logviewer?job_id=332583137&repo=autoland&lineNumber=70490

TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/minimize_window/minimize.py | expected OK

Blocks: 1698122
No longer blocks: 1697195

Sending this bug to gfx-triage.

Does this webdriver test time out when is SW-WR enabled without Fission? This seems like a SW-WR bug.

Blocks: gfx-triage

I will attempt to reproduce.

Flags: needinfo?(bwerth)

Tracking for Fission M7a Beta. TBD whether SW-WR will block Fission MVP.

Fission Milestone: ? → M7a

I can't reproduce this on macOS. Treeherder seems to say it has only been sighted on Windows. I'll take myself off needinfo and we'll discuss it again in triage.

Flags: needinfo?(bwerth)

Using the following on Windows -

mach wpt testing/web-platform/tests/webdriver/tests/minimize_window/minimize.py --enable-fission --setpref="gfx.webrender.software=true"

I can't reproduce. I want to confirm I'm actually getting the config I'm requesting.

Chris, what config are we testing in 'opt-web-platform-tests-wdspec-fis-e10s-1'? Does that e10s-1 imply some sort of single content process test environment?

Flags: needinfo?(cpeterson)

also tried -

mach wpt testing/web-platform/tests/webdriver/tests/minimize_window/minimize.py --enable-fission --setpref="gfx.webrender.software=true" --setpref="gfx.webrender.software.d3d11=false"

Interesting that this test fails when marionette is trying to make the window fullscreen, and gives the browser 5 seconds to complete the operation. This makes me think it's some sort of timeout related to slow painting. Definitely doesn't reproduce on my beefy workstation.

(In reply to Jim Mathies [:jimm] from comment #5)

Chris, what config are we testing in 'opt-web-platform-tests-wdspec-fis-e10s-1'? Does that e10s-1 imply some sort of single content process test environment?

The "e10s-1" just means this test is running with content processes (not the pre-e10s "1proc") and is in the first batch of tests. Tests with many sub-test cases are automatically split into small batches to reduce timeouts.

So test-windows10-64-qr/opt-web-platform-tests-wdspec-fis-e10s-1 is opt Windows build running on 64-bit Windows 10 with WebRender ("qr") and Fission ("fis") enabled.

Flags: needinfo?(cpeterson)
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.