Naming consistency for CacheIR Health Report
Categories
(Core :: JavaScript Engine: JIT, defect, P5)
Tracking
()
Tracking | Status | |
---|---|---|
firefox89 | --- | fixed |
People
(Reporter: caroline, Assigned: cOde.A4sh, Mentored)
References
(Blocks 1 open bug)
Details
(Keywords: good-first-bug)
Attachments
(1 file)
Note: this bug is currently reserved for Outreachy applicants for the Spring/Summer 2021 cycle. If it has not been completed by the end of the application cycle, we will open it up.
This bug doesn't require knowledge of SpiderMonkey's CacheIR optimization or the CacheIRHealth report. Though it might be nice to get a general idea of both from the meta bug this is attached to.
As the CacheIR health report evolved, so did the name. Thus there are some inconsistencies in the naming schema. I believe naming everything in terms of CacheIRHealthReport is the most straight forward. This involves a few changes to the naming in CacheIRHealth.h and CacheIRHealth.cpp. For example, naming rateIC
and rateScript
to something more consistent, renaming the RateMyCacheIR environment variable, renaming the shell function, updating the comments to the new function name, etc.
Updated•4 years ago
|
Reporter | ||
Comment 2•4 years ago
|
||
Sounds great, if you have any questions you can reach out to me on matrix in either the SpiderMonkey channel or personally (my username is caroline). Thank you!
Updated•4 years ago
|
Comment 5•4 years ago
|
||
bugherder |
Description
•