Closed Bug 1697862 Opened 2 years ago Closed 23 days ago

Enable AVX2 processing for sound in libwebrtc

Categories

(Core :: WebRTC, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1766646

People

(Reporter: ng, Unassigned)

References

Details

We need to cherry pick some fixes from upstream, and get their build working with clang-cl. When compiling with clang-cl one doesn't automatically get the intrinsic definitions when pulling in the the broad intrinsic header which then pulls in specific headers depending on the build environment. Skia seems to have a local(?) modification that works around this by pulling in the specific headers needed. Each of the places where AVX2 is used would need to be similarly modified, so we could add a header which does that and change the existing includes to pull that header instead.

Probably not a S2
Reminder, S2 means: (Serious) Major functionality/product severely impaired or a high impact issue and a satisfactory workaround does not exist

And it seems to be part of the backlog now

Severity: S2 → S3
Priority: P2 → P3

This was fixed in the latest libwebrtc update.

Status: NEW → RESOLVED
Closed: 23 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: libwebrtc-fast-forward
You need to log in before you can comment on or make changes to this bug.