Closed Bug 1697901 Opened 9 months ago Closed 3 months ago

[network markers] There's no end marker when a channel is stopped early

Categories

(Core :: Gecko Profiler, defect, P3)

defect

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: julienw, Assigned: julienw)

References

(Depends on 1 open bug, Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(4 files, 1 obsolete file)

Coming from Florian:

Lots of network markers that don't end in this profile: https://share.firefox.dev/38vGO7u
it's very likely because the channel is canceled at https://searchfox.org/mozilla-central/rev/f6ffb71dca9eb491e85aa95042380b2602008b00/testing/mochitest/BrowserTestUtils/BrowserTestUtils.jsm#1511

I think this is the case for a bunch of other cases too:

  • when a request is aborted because of tracking protection
  • when in offline mode

I think we'll introduce one or more new "end status" besides LOAD_STOP and LOAD_REDIRECT.

Severity: -- → S3
Priority: -- → P3
See Also: → 1654881

This patch supports channel cancelations with network markers.

Because of all the possible ways to stop a channel and hence all
possible end markers, it also introduces a new boolean to reduce the
complexity. Indeed it happens that 2 "end functions" are called, but we
need to insert only 1 end marker to have a well-formed result in the
Profiler frontend.

Assignee: nobody → felash
Status: NEW → ASSIGNED

This patch supports channel cancelations with network markers.

Depends on: 1724950
Attachment #9235392 - Attachment description: Bug 1697901 - [network markers] Support channel cancelation r=valentin!,gerald! → Bug 1697901 - [network markers] Support channel cancelation r=gerald!

Intercepted requests can also be canceled.

Depends on D122111

This ensures our users will use the latest version of the frontend when
capturing 'cancel' network markers.

Depends on D123254

Requests may be canceled before AsyncOpen is even called. In that case
we don't want to add START markers, and we don't want to add CANCEL
markers for these requests that didn't even start yet.

Depends on D123255

Attachment #9235414 - Attachment is obsolete: true
Pushed by jwajsberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fddd1f768e10
[network markers] Support channel cancelation r=valentin,gerald,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/d5983e247212
[network markers] Support channel cancelation in service workers too r=necko-reviewers,kershaw
https://hg.mozilla.org/integration/autoland/rev/8e4d2f5bcea1
[network markers] Bump the profile version to 24 r=gerald
https://hg.mozilla.org/integration/autoland/rev/348a3786a29a
[network markers] Move the START marker slightly later so that we don't add it for canceled requests r=necko-reviewers,dragana
Regressions: 1727056
You need to log in before you can comment on or make changes to this bug.