The sidebar will not appear.

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: lgoldman, Assigned: sfraser_bugs)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020919
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020919

The sidebar will not appear, either through the Show Bookmarks command or the
toggle button.

Reproducible: Always

Steps to Reproduce:
1. Click the Sidebar toggle button.
2. Choose the Show Bookmarks command.
3.

Actual Results:  
Sidebar will not appear.

Expected Results:  
Sidebar should appear in its usual place.
(Assignee)

Comment 1

16 years ago
Er, pink?
wfm *shrug*

Comment 3

16 years ago
WorksForMe using Chimera/2002091704 on 10.1.5.
(Reporter)

Comment 4

16 years ago
The problem started occuring with the Wednesday's build (2002091804), and I am
using OS 10.2.1.
(Assignee)

Comment 5

16 years ago
Did you use ChimeraKnight to install the build? Does it happen if you trash your
old Navigator, and download a new one? Is there any output on the console?
(Reporter)

Comment 6

16 years ago
I have trashed and replaced Navigator with each daily build.  Didn't know about
ChimeraKnight before--I just used it, and the problem is still there.  I'm not
familiar with the console.  Where do I find it?
(Assignee)

Comment 7

16 years ago
Applications/Utilities/Console
(Reporter)

Comment 8

16 years ago
Here is the console output from my operation of ChimeraKnight:

Sep 20 18:44:56 Lawrence-Goldmans-Computer WindowServer[238]: orderWindow:
Invalid other window

Sep 20 18:44:56 Lawrence-Goldmans-Computer WindowServer[238]:
CGXOrderWinsAndPanels: error ordering window

Sep 20 18:45:06 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]: disk1s2   
hfs      no    no    Chimera          [not mounted]    

Sep 20 18:45:06 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]: disk1s2   
hfs      no    no    Chimera          /Volumes/Chimera 

Sep 20 18:46:03 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]: Someone
(pid = (517)) isn't responding to a sent disk acknowledgement request. That
client has been disconnected. 

Sep 20 18:46:03 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]:
(autodiskmount.tproj/DiskArbitrationServerMain.c:4412) mach_msg failed:
{0x10004003} (ipc/rcv) timed out 

Sep 20 18:46:03 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]:
(autodiskmount.tproj/DiskArbitrationServerMain.c:410) received unrecognized
message (id=0x41) on notify port 

Sep 20 18:46:03 Lawrence-Goldmans-Computer /sbin/autodiskmount[243]:
DiskArbUnmountPreNotifyAck_async_rpc(pid = 517, diskIdentifier = 'disk1s2',
errorCode = 0): no known client with this pid. 

2002-09-20 18:47:07.212 Eudora[449] CFLog (20): Eudora:  You have new mail.
Sep 20 18:47:21 Lawrence-Goldmans-Computer crashdump: Crash report written to:
/Users/lgoldman/Library/Logs/CrashReporter/Eudora.crash.log

Sep 20 18:48:33 Lawrence-Goldmans-Computer WindowServer[238]: CGXDisableUpdate:
Updates disabled by connection 0x7b0b for over 1.000000 seconds

nsPluginsDir::IsPluginFile:  checking
/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin
found bundled plugin
'/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin'.
[NSPR:  bundle loaded succesfully:
/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin]
[loaded plugin /Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin]
nsPluginsDir::IsPluginFile:  checking /Users/lgoldman/Library/Internet
Plug-Ins/.DS_Store
nsPluginsDir::IsPluginFile:  checking /Users/lgoldman/Library/Internet
Plug-Ins/SpeedDownload Browser Plugin
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/DRM Plugin.bundle
found bundled plugin '/Library/Internet Plug-Ins/DRM Plugin.bundle'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/flashplayer.xpt
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Java Applet
Plugin Enabler
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Java Applet.plugin
found bundled plugin '/Library/Internet Plug-Ins/Java Applet.plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet
Plug-Ins/nsIQTScriptablePlugin.xpt
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/PDFViewer
found plugin '/Library/Internet Plug-Ins/PDFViewer'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/QuickTime
Plugin.plugin
found bundled plugin '/Library/Internet Plug-Ins/QuickTime Plugin.plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet
Plug-Ins/ReadMeSVGViewer.html
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/RealPlayer Plugin
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Shockwave Flash
NP-PPC
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/SVG Plugin
found plugin '/Library/Internet Plug-Ins/SVG Plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/SVGViewer.zip
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Windows Media
Plugin
found bundled plugin '/Library/Internet Plug-Ins/Windows Media Plugin'.
### MRJPlugin:  getPluginBundle() here. ###
### MRJPlugin:  CFBundleGetBundleWithIdentifier() succeeded. ###
### MRJPlugin:  CFURLGetFSRef() succeeded. ###
nsPluginsDir::IsPluginFile:  checking
/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin
found bundled plugin
'/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin'.
nsPluginsDir::IsPluginFile:  checking /Users/lgoldman/Library/Internet
Plug-Ins/.DS_Store
nsPluginsDir::IsPluginFile:  checking /Users/lgoldman/Library/Internet
Plug-Ins/SpeedDownload Browser Plugin
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/DRM Plugin.bundle
found bundled plugin '/Library/Internet Plug-Ins/DRM Plugin.bundle'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/flashplayer.xpt
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Java Applet
Plugin Enabler
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Java Applet.plugin
found bundled plugin '/Library/Internet Plug-Ins/Java Applet.plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet
Plug-Ins/nsIQTScriptablePlugin.xpt
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/PDFViewer
found plugin '/Library/Internet Plug-Ins/PDFViewer'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/QuickTime
Plugin.plugin
found bundled plugin '/Library/Internet Plug-Ins/QuickTime Plugin.plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet
Plug-Ins/ReadMeSVGViewer.html
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/RealPlayer Plugin
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Shockwave Flash
NP-PPC
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/SVG Plugin
found plugin '/Library/Internet Plug-Ins/SVG Plugin'.
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/SVGViewer.zip
nsPluginsDir::IsPluginFile:  checking /Library/Internet Plug-Ins/Windows Media
Plugin
found bundled plugin '/Library/Internet Plug-Ins/Windows Media Plugin'.
[NSPR:  bundle loaded succesfully:
/Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin]
[loaded plugin /Applications/Navigator.app/Contents/MacOS/plugins/MRJPlugin.plugin]
### MRJPlugin:  getPluginBundle() here. ###
### MRJPlugin:  CFBundleGetBundleWithIdentifier() succeeded. ###
### MRJPlugin:  CFURLGetFSRef() succeeded. ###
libpng error: Too much data in IDAT chunks
(Assignee)

Comment 9

16 years ago
libpng error: Too much data in IDAT chunks

That looks suspicious. What images try to load when you open the sidebar? Do you
have the pref on to show favicons in the bookmarks panel? If you move your
Chimera profile folder aside (in ~/Library/Application Support/Chimera) and run
again, does the problem still happen?
(Reporter)

Comment 10

16 years ago
I removed the Profile folder, but it didn't help.  I have not implemented
favicons.  The only modification I made was to include the history list in the
sidebar, through an entry in the all.js file.  That worked fine for several
days, prior to my ever having this problem.  In the sidebar, there were icons at
the top for bookmarks and history, and four icons underneath, including the
delete button.
(Reporter)

Comment 11

16 years ago
After much trashing/re-downloading, I have observed: in the September 9 original
0.5 release, the sidebar works correctly.  But in the current build
(2002092004), the sidebar functions, but the browser window does not resize,
thus leaving the sidebar hidden from view.

Comment 12

16 years ago
I have observed the same thing.  It only appears to not show it when the browser
is set to fill the entire screen. This is with build 2002092004.
(Assignee)

Comment 13

16 years ago
Do you have the window maximized (filling the screen) when you try to show the
sidebar? Have you tried shrinking the window down first?
(Reporter)

Comment 14

16 years ago
The browser is usually filling the screen, which is why I can't see the sidebar.
 If I shrink down the browser window, there is room for the sidebar to
appear--otherwise, it stays hidden behind the browser.

Comment 15

16 years ago
It's my understanding that the change in the Sidebar's behavior was made to
match the "correct" behavior of Apple apps like Mail, where the sidebar expands
on whichever side has more room and the main window does not resize. The problem
with this is that browser windows are quite commonly set to fill the entire
width of the screen (especially on laptops and smaller monitors). In my opinion,
the previous behavior of the Chimera sidebar, where it always expands on the
right and resizes the main window if necessary, is much more appopriate for a
web browser. My iBook, for example, can only display 800x600 pixels. To maximize
my ability to view web pages, I always keep my Chimera window expanded to the
full width of the screen and typically use tabbed browsing rather than opening
new windows.
(Reporter)

Comment 16

16 years ago
I completely agree--the previous method was far better.  Why should I sacrifice
a quarter of my browser window just to occasionally view the sidebar?
yes, after using it this weekend on my powerbook, i agree. having the sidebar go
off the side of the screen is pretty crappy. It's non-standard, but i think this
is one place where it's worth it.

I'll flip the ifdef back and reopen the other bug that i closed when i "fixed" this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
yep works for me. vrfy'ing with 20025.09.24.12.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.