Closed Bug 1698153 Opened 3 months ago Closed 25 days ago

RTAMO users should be excluded from nimbus experiment

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
90 Branch
Iteration:
90.3 - May 17 - May 30
Tracking Status
firefox89 --- wontfix
firefox90 --- verified

People

(Reporter: pdahiya, Assigned: emcminn)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

Current RTAMO onboarding implementation lets RTAMO users enroll in nimbus experiments. See bug 1697793

We should change this behavior and exclude RTAMO users from firstrun onboarding experiments targeting , fix will need to check for attribution data and return early before retrieving content from Experiment Feature Config - window.AWGetFeatureConfig();

https://searchfox.org/mozilla-central/source/browser/components/newtab/content-src/aboutwelcome/aboutwelcome.jsx#113

The Bugbug bot thinks this bug should belong to the 'Firefox::Messaging System' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: General → Messaging System
Assignee: nobody → pdahiya
Severity: -- → S3
Priority: -- → P1

Let's explore how we can update firstrun nimbus targeting to exclude RTAMO users

Duplicate of this bug: 1697793

I've tried inverting the checks so that RTAMO runs first, with an early return.
https://share.firefox.dev/3rWvicQ <-- profiling results with RTAMO first

https://share.firefox.dev/2QiI4ob <--profiling results from m-c, for comparison

moving back to triage

Priority: P1 → --
Summary: RTAMO users should be excluded from nimbus experiment targeting → RTAMO users should be excluded from nimbus experiment

We shouldn't need this if we're excluding this in code (by checking RTAMO attribution before checking experiment enrollment).

Assignee: pdahiya → emcminn
Priority: -- → P1
Attachment #9221425 - Attachment description: WIP: Bug 1698153 - Check for RTAMO before experiment → Bug 1698153 - Check for RTAMO before experiment
Iteration: --- → 90.3 - May 17 - May 30
Status: NEW → RESOLVED
Closed: 25 days ago
Resolution: --- → FIXED
See Also: → 1711700
Target Milestone: --- → 90 Branch
Attachment #9221425 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.