Closed Bug 1698619 Opened 2 months ago Closed 1 month ago

"New Windows and Tabs" URL does not update when URL in manifest changes

Categories

(WebExtensions :: Untriaged, defect, P2)

Firefox 86
defect

Tracking

(firefox86 wontfix, firefox87 wontfix, firefox88 wontfix, firefox89 verified)

VERIFIED FIXED
89 Branch
Tracking Status
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- verified

People

(Reporter: lucaseverett, Assigned: mixedpuppy)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

I published an update for my web-extension Toolbar Dial. In the update the URLs in the manifest for homepage and newtab were changed from "dist/index.html" to "index.html". This resulted in the browser showing an error after updating because Firefox was still referencing the original URL instead of the new one.

Actual results:

When using an extension to override "Homepage and new windows" or "New tabs", the URL used to display the override does not automatically update if the URLs referenced in the manifest for homepage and newtab change.

Expected results:

Upon manifest changes, the browser should update the URL used for opening new tabs and windows rather than continuing to use the URL that was in the manifest upon original install.

As of now the only solution is to disable and then re-enable the extension for the browser to use the updated URLs in the manifest.

The Bugbug bot thinks this bug should belong to the 'WebExtensions::Untriaged' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Product: Firefox → WebExtensions

After doing some testing using about:debugging to load a temporary add-on and then changing the URL in the manifest and reloading, it seems that only the homepage is affected. New tab actually seems to be fine and not broken like I originally thought it was. Homepage is definitely an issue though and can be easily reproduced using about:debugging.

Hello,

I’ve reproduced the issue on the latest Nightly (88.0a1/20210316214855), Beta (87.0/20210315170302) and Release (86.0.1/20210310152336) under Windows 10 x64 and Ubuntu 16.04 LTS, using the method proposed in Comment 2.

STR:

  1. I’ve downloaded the extension from AMO and changed the homepage and new tab URLs to include the “dist/” string in the manifest.
  2. Loaded the add-on into the browser via about:debugging and opened two new tabs. One was kept as is and on the other one I clicked on the home button. Both URLs contained the “dist/” string.
  3. Changed the homepage and new tab URLs back to their original state in the manifest ( i.e “index.html”) and reloaded the extension.
  4. Opened two new tabs as in Step 2. The new tab URL was updated correctly, while the homepage URL remained as mentioned in Step 2, with “dist/” in it.

As mentioned in the original description, the homepage URL got updated to the one in the manifest only after disabling and then re-enabling the extension.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mixedpuppy)

After digging into this I also saw that this broke the ability to localize the homepage value even though it is documented.

The change I'll push is that we allow homepage to be changed, as we do for newtab, but if it changes to an external (http) url we will force a re-confirmation from the user. so long as the url changes to an extension internal url, it will not re-prompt.

Assignee: nobody → mixedpuppy
Severity: -- → S2
Flags: needinfo?(mixedpuppy)
Priority: -- → P2
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ad5bd294e1b
fix updating homepage setting on updates and for localization r=robwu
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified the fix on the latest Nightly (89.0a1/20210413214314) under Windows 10 x64 and Ubuntu 16.04 LTS, using the steps performed in Comment 3.

Upon changing the homepage and new tab URLs in the manifest from “dist/index.html” to “index.html” and reloading the add-on, both homepage and new tab URLs got updated accordingly, confirming the fix.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.