onchange in select isn't called when you scroll through the select list

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Jonathan Sieber, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910

netscape 4.79 and ie both call the onchange action when you change the select by
scrolling up and down the list.  this lets me update an image to correspond to
the currently shown value.

mozilla only seems to call it when you actually select an option by clicking on it.

Reproducible: Always

Steps to Reproduce:
1. load the page
2. first try and select by clicking on an item.
3. now just scroll up and down the list (w/o opening it) using the arrow keys
4. try in netscape and see the difference

Actual Results:  
2. the font sample changes (if you comment out the alert you can see when the
onchange function is getting called)
3. the onchange is not called until the control looses focus

Expected Results:  
2. the same
3. the onchange is called on every up arrow or down arrow and the font sample
changes on every keystroke

Comment 1

15 years ago
This is deliberate.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.