Closed Bug 1698981 Opened 6 months ago Closed 6 months ago

Focus rings are not visible in (at least) permission panels when Proton is enabled

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [proton-door-hangers] [access-s3])

Attachments

(1 file)

We've got focus rings on the checkboxes and menulists, but we appear to be missing them on the buttons.

Whiteboard: [proton-door-hangers] → [proton-door-hangers] [access-s3]
Priority: -- → P1
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/177159d72cd3
Show focus rings for panel footer buttons, both normal and menulike. r=Itiel,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified the fix using Firefox 89.0b4 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.15. On Windows and Ubuntu the issue is not reproducing anymore.

However on macOS the focus remains only on "Learn more" hyperlink and it's not visible in some cases (or it's hard to see if Dark Theme is used). But I would like to mention that this issue is reproducing with Proton disabled as well.

Flags: needinfo?(mconley)

Thanks, Oana. Can a new bug be filed for the issue you mentioned in comment 4?

Flags: needinfo?(mconley) → needinfo?(oana.botisan)

According to comment 4. I will mark this bug as verified fixed.
The other issues that were mentioned can be tracked using bug 1715211 and bug 1715207.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(oana.botisan)
You need to log in before you can comment on or make changes to this bug.