Closed Bug 1699964 Opened 6 months ago Closed 3 months ago

[css-content] Implement 'content: none' for elements

Categories

(Core :: Layout, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: mats, Assigned: mats)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

https://drafts.csswg.org/css-content/#valdef-content-none

On elements, this inhibits the children of the element from being rendered as children of this element, as if the element was empty.
...
In neither case does it prevent any pseudo-elements which have this element or pseudo-element as an originating element from being generated.

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:mats, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mats)
Flags: needinfo?(emilio)
Flags: needinfo?(emilio)
Flags: needinfo?(mats)
Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dcc1d0a10a11
[css-content] Implement 'content: none' for elements.  r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29458 for changes under testing/web-platform/tests
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Upstream PR merged by moz-wptsync-bot
Regressions: 1719239
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/715d1e5aebe0
Apply clang-format to nsCSSFrameConstructor.cpp. r=layout-reviewers,AlaskanEmily

Once the PRs are merged this will be added to Experimental features and to BCD.

FYI, this feature was disabled in bug 1719239 due to web-compat issues.
Filed spec issue: https://github.com/w3c/csswg-drafts/issues/6503

You need to log in before you can comment on or make changes to this bug.