Closed Bug 1700263 Opened 2 years ago Closed 1 year ago

Framework for building and sending a11y cache data from content to parent

Categories

(Core :: Disability Access APIs, task)

task

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: Jamie, Assigned: eeejay)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

We need to be able to:

  1. Build cache data in the content process; i.e. fetch relevant properties from LocalAccessibles, associate them with the right property identifiers and types and shove them in a data structure for transmission. We'll probably want to be able to support building for specific properties and LocalAccessibles, as well as building for a subtree. For example, for the initial transmit, we'll probably want most properties for the entire subtree, whereas invalidation may only invalidate specific properties for specific LocalAccessibles.
  2. Transmit that data from content to parent using IPDL.
  3. Unpack that data into RemoteAccessible caches in the parent process.
Blocks: 1700264

This will allow us to use the list of accessibles to be serialized later
for pushing a cache. The single array also gives us an opportunity to
paginate the cache, if needed.

This is a good place to formalize the following naming convention:

  • A "field" is and direct accessible getter method (name,
    role, value, min, max, etc.)
  • An "attribute" is a member of the "attributes" field.

With that said, I think AccAttributes should probably be named
AccProperties or something of the sort. Might leave that for another
time.

Depends on D121923

Assignee: nobody → eitan
Attachment #9234983 - Attachment description: WIP: Bug 1700263 - Split serialize function into a flatten, and then serialize. → Bug 1700263 - Split serialize function into a flatten, and then serialize. r?Jamie
Status: NEW → ASSIGNED
Attachment #9234984 - Attachment description: WIP: Bug 1700263 - Implement async Cache protocol method. → Bug 1700263 - Implement async Cache protocol method. r?Jamie
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b193471aed7
Split serialize function into a flatten, and then serialize. r=Jamie
https://hg.mozilla.org/integration/autoland/rev/702b95989655
Implement async Cache protocol method. r=Jamie
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Regressions: 1726391
Duplicate of this bug: 1700260
You need to log in before you can comment on or make changes to this bug.