Closed Bug 1700308 Opened 2 months ago Closed 2 months ago

[Experiment] The "Pin Firefox to your taskbar" slide from the "Treatment A" and "Treatment B" branches no longer respects the UI specifications.

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
Iteration:
89.1 - Mar 22 - Apr 4
Tracking Status
firefox86 --- unaffected
firefox87 --- verified
firefox88 --- unaffected
firefox89 --- unaffected

People

(Reporter: mcoman, Assigned: Mardak)

References

Details

Attachments

(1 file)

Attached image ss of the issue.png

[Affected versions]:

  • Firefox 87.0 - Build ID: 20210318103112

[Affected Platforms]:

  • Windows 10 x64

[Prerequisites]:

  • Have this user.js saved to your PC.
  • Have the "app.update.channel" set to "release".

[Steps to reproduce]:

  1. Create a new profile but do not open the browser.
  2. Go to the profile folder and paste the "user.js" from prerequisites.
  3. Open the browser with the profile from prerequisites using the "--first-startup" argument.
  4. Observe the first slide of the "about:welcome" page.

[Expected result]:

  • The "Pin Firefox to your taskbar" slide contains the following elements:
    • The "Have an account? Sign in" test string, with the "Sign in" hyperlinked, is displayed in the top-right part of the page.
    • The Firefox logo is displayed in the middle-top part of the page.
    • The "Pin Firefox to your taskbar" title is displayed on black bolded characters under the Firefox logo.
    • The "Speed, safety, and privacy every time you browse." text string written in grey characters is displayed under the title.
    • An image describing the pin to taskbar process is displayed under the description.
    • A blue button with the "Pin to Taskbar" label written in white is displayed under the "pin-illustration" image.
    • The "Not now" hyperlink is displayed under the button.

[Actual result]:

  • The "pin-illustration" image is no longer displayed and the "Pin" label is wrongly displayed on the primary button instead of the "Pin to Taskbar" one.

[Additional Notes]:

  • This issue is also reproducible on the "Treatment B" branch.
  • This issue is not reproducible with the old experiment setup from the "Remote Settings - Stage" server.
  • Attached a screenshot of the issue.

@Ed, could you please take a look over this issue?

Flags: needinfo?(edilee)

Thanks for catching this. I've manually copied over the values from the stage remote settings record json instead of copying over the values from stage nimbus interface. Looks like changes directly to remote settings don't reflect back to nimbus.

The only extra change relative to stage remote settings should be Treatment D help text says "This will pin Firefox to taskbar and open settings" instead of "Pin Firefox to taskbar and open settings"

This should be fixed on prod preview now:
https://firefox.settings.services.mozilla.com/v1/buckets/main/collections/nimbus-preview/records/1-click-pin-during-onboarding

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(edilee)
Resolution: --- → FIXED
Assignee: nobody → edilee
Iteration: --- → 89.1 - Mar 22 - Apr 4
Priority: -- → P1

This issue was part of the work done on PI-987. Considering this I will mark it as Verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.