Closed Bug 1700452 Opened 1 year ago Closed 1 year ago

Update libdav1d to c54add02 for Firefox 90

Categories

(Core :: Audio/Video: Playback, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: jbauman, Assigned: jbauman)

References

Details

(Keywords: perf-alert)

Attachments

(1 file)

Since we want to update our dav1d sources on a regular cadence, and it's best to do this at the beginning of a nightly cycle. On April 19, 2021, we'll choose an appropriate revision or tag to update to.

Duplicate of this bug: 1710557

https://code.videolan.org/videolan/dav1d/-/blob/master/NEWS

"0.9.0 is a major version of dav1d, adding notably 10b acceleration on x64."
"x86 (64bit) AVX2 implementation of most 10b/12b functions, which should provide
a large boost for high-bitdepth decoding on modern x86 computers and servers."

Depends on: 1712832

Turns out we can work around 1712832, by not building files on win32 when their output would be empty

No longer depends on: 1712832
See Also: → 1712832
Summary: Update libdav1d for Firefox 90 → Update libdav1d to c54add02 for Firefox 90
Pushed by jbauman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad7e380bb908
Update libdav1d for Firefox 90. r=mjf
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Blocks: 1713361

== Change summary for alert #30232 (as of Sat, 29 May 2021 18:13:03 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
26% wikipedia dcf windows10-64-shippable-qr cold webrender 1,945.35 -> 1,446.75
15% cnn fnbpaint macosx1014-64-shippable-qr cold webrender 1,451.98 -> 1,240.92
14% imdb fnbpaint macosx1014-64-shippable-qr cold webrender 1,305.29 -> 1,121.12
14% imdb FirstVisualChange macosx1014-64-shippable-qr cold webrender 1,576.67 -> 1,360.00
14% imdb dcf macosx1014-64-shippable-qr cold webrender 1,332.06 -> 1,150.54
... ... ... ... ... ...
2% microsoft fnbpaint windows10-64-shippable-qr warm webrender 183.42 -> 179.17

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=30232

Keywords: perf-alert
Blocks: 1716453
You need to log in before you can comment on or make changes to this bug.