Closed Bug 1700835 Opened 10 months ago Closed 10 months ago

Remove or update probes expiring in Firefox 90: telemetry.*

Categories

(Toolkit :: Telemetry, task, P1)

task
Points:
1

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox88 --- fixed
firefox89 --- fixed

People

(Reporter: telemetry-probes, Assigned: chutten)

References

(Blocks 1 open bug)

Details

(Whiteboard: [probe-expiry-alert])

Attachments

(3 files)

The following Firefox probes will expire in the next major Firefox nightly release: version 90 [1].

telemetry.state_file_save_errors
telemetry.generated_new_client_id
telemetry.loaded_client_id_doesnt_match_pref

What to do about this:

  1. If one, some, or all of the metrics are no longer needed, please remove them from their definitions files (Histograms.json, Scalars.yaml, Events.yaml).
  2. If one, some, or all of the metrics are still required, please submit a Data Collection Review [2] and patch to extend their expiry. There is a shorter form for data collection renewal [3].

If you have any problems, please ask for help on the #data-help Slack channel or the #telemetry Matrix room at https://chat.mozilla.org/#/room/#telemetry:mozilla.org. We'll give you a hand.

Your Friendly, Neighborhood Telemetry Team

[1] https://wiki.mozilla.org/Release_Management/Calendar
[2] https://wiki.mozilla.org/Firefox/Data_Collection
[3] https://github.com/mozilla/data-review/blob/master/renewal_request.md

This is an automated message sent from probe-scraper. See https://github.com/mozilla/probe-scraper for details.

Flags: needinfo?(chutten)

I really expected to not need these, but the remediation doesn't seem to have clearly worked. So I need to renew these for a least a few versions : (

Assignee: nobody → chutten
Severity: -- → S4
Status: NEW → ASSIGNED
Points: --- → 1
Flags: needinfo?(chutten)
Priority: -- → P1
Attachment #9211866 - Flags: data-review?(tlong)
Attached file data collection review

(for the new collections)

Attachment #9211868 - Flags: data-review?(tlong)

Comment on attachment 9211866 [details]
data collection renewal request

  1. Is the provided Data Collection Review complete, correct, and data-review+ by a Data Steward?
    Yes

  2. Is the data collection covered by the existing Firefox Privacy Notice?
    Yes

Data Review Result

data-review+

Attachment #9211866 - Flags: data-review?(tlong) → data-review+

Comment on attachment 9211868 [details]
data collection review

Data Review Form

  1. Is there or will there be documentation that describes the schema for the ultimate data set in a public, complete, and accurate way?
    Yes, in Histograms.json, Scalars.yaml, and/or in Events.yaml, and in the Probe Dictionary

  2. Is there a control mechanism that allows the user to turn the data collection on and off?
    Yes, through through the data choices preference in settings.

  3. If the request is for permanent data collection, is there someone who will monitor the data over time?
    N/A, set to expire in Firefox 94

  4. Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?
    Category 1, technical data.

  5. Is the data collection request for default-on or default-off?
    Default on

  6. Does the instrumentation include the addition of any new identifiers?
    No

  7. Is the data collection covered by the existing Firefox privacy notice?
    Yes

  8. Does there need to be a check-in in the future to determine whether to renew the data?
    No

  9. Does the data collection use a third-party collection tool?
    No

Data Review Result

data-review+

Attachment #9211868 - Flags: data-review?(tlong) → data-review+
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16f1061759ab
Renew client_id probes and add three new ones r=TravisLong
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Comment on attachment 9211870 [details]
Bug 1700835 - Renew client_id probes and add three new ones r?TravisLong!

Beta/Release Uplift Approval Request

  • User impact if declined: Slower access to full instrumentation about weirdness we're seeing in the fundamental unit of data deduplication: the Telemetry client_id
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is not risky because it is instrumentation-only. But it touches client_id, which is kind of a Big Deal, so it's not zero risk.

I've checked that DAU and deletion-request numbers remain roughly stable in the three days since this has shipped. But Nightly is a noisy beast, so subtle changes could be lost in the noise.

  • String changes made/needed:
Attachment #9211870 - Flags: approval-mozilla-beta?
Blocks: 1700188

Comment on attachment 9211870 [details]
Bug 1700835 - Renew client_id probes and add three new ones r?TravisLong!

Thanks for double-checking the Nightly impact. Approved for 88.0b6.

Attachment #9211870 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: → 1725500
You need to log in before you can comment on or make changes to this bug.