Closed Bug 1700904 Opened 2 months ago Closed 13 days ago

Enable the new cookies and IndexedDB storage resources by default

Categories

(DevTools :: Storage Inspector, task)

task

Tracking

(Fission Milestone:M7a, firefox90 fixed)

RESOLVED FIXED
90 Branch
Fission Milestone M7a
Tracking Status
firefox90 --- fixed

People

(Reporter: ladybenko, Assigned: ladybenko)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-m3-mvp)

Attachments

(1 file)

The new cookies storage resource with support for Fission is walled behind the devtools.testing.enableWatcherSupport pref. We should remove this guard in the watcher once we have tested it for a bit.

See https://phabricator.services.mozilla.com/D108040?id=411601#inline-606708 discussion

Whiteboard: dt-fission-m3-mvp → dt-fission-m3-triage
Whiteboard: dt-fission-m3-triage → dt-fission-m3-mvp
Fission Milestone: --- → M8
Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Summary: Enable the new cookies storage resource by default → Enable the new cookies and IndexedDB storage resources by default

This removes the testing enableServerWatcherSupport flag for indexedDB and cookies resources. As a consequence of this, some tests that were previously marked as failing on fission now pass, so they have been re-enabled as well.

Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/751d66c96a08
[devtools] remove guards for new cookies and indexeddb resources r=ochameau
Status: ASSIGNED → RESOLVED
Closed: 13 days ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Fission Milestone: M8 → M7a
Duplicate of this bug: 1691613
Duplicate of this bug: 1691614
Duplicate of this bug: 1691615
Duplicate of this bug: 1691616
Duplicate of this bug: 1691619
Duplicate of this bug: 1691618
Duplicate of this bug: 1691617
You need to log in before you can comment on or make changes to this bug.