Closed Bug 1701347 Opened 8 months ago Closed 8 months ago

Menulist chrome tests are unhappy with proton enabled

Categories

(Firefox :: Theme, task)

Desktop
All
task

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: Gijs, Assigned: mconley)

References

Details

(Whiteboard: [proton-foundations])

Attachments

(1 file)

Mike kindly offered to look into this.

Severity: -- → N/A
Type: defect → task
Whiteboard: [proton-foundations]

Trypush failure reference: https://treeherder.mozilla.org/jobs?repo=try&revision=3ed214b2325b5bf83933eaae85ee85ffb66fc768&selectedTaskRun=HYU1KtDpT52ZqEj4gvuW_g.0

With stuff like TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_menulist_position.xhtml | Labels horizontally aligned for index 0

This blocks enabling Proton by default in Nightly, otherwise we're gonna get backed out by test failures, so suggesting a P1.

I can easily reproduce this locally. Investigating...

Err, please disregard that last comment, it looks like that is related to proton context menus, I was looking at the wrong trypush...

Yeah, the failures in test_menulist_position.xhtml seem to be related to the vertical centering of the menulist popups on macOS. Looking for an acceptable solution.

The test is unhappy because it's trying to test that the menupopup on macOS has the current item selection centered over top of the menulist itself. This is a native behaviour that will eventually go away once bug 1699532 is fixed, although this doesn't currently block MR1.

In the meantime, we'll make the test use the old-school "native"-style menulist so that it passes.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5ca109977007
Use a native menulist in test_menulist_position.xhtml. r=Gijs
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.