Closed Bug 1701977 Opened 1 year ago Closed 1 year ago

[wayland] Enable Webrender on all compositors on Mesa Intel/AMD

Categories

(Core :: Graphics, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: rmader, Assigned: rmader)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Following up on bug 1640115 comment 10

We do not yet enable Wayland by default anywhere and we only need to care for four major compositors: Weston, Mutter, KWin and Sway/wlroots.

Weston is only for testing purposes, Mutter has been well tested on Fedora for a while now, Sway appears to be fine (bug 1640115 comment 10) and KWin only enters a wider audience right now.

Lets enable Webrender on all of them and not invest more into the basic backend.

Open question: should we fall back to SW-WR instead of basic already if HW-WR fails?

Martin, Vlad, Andrew - any resistance again this?

Flags: needinfo?(vlad.zahorodnii)
Flags: needinfo?(stransky)
Flags: needinfo?(aosmond)
Duplicate of this bug: 1640115

Open question: should we fall back to SW-WR instead of basic already if HW-WR fails?

In an impromptu test, the total CPU usage for playing a YouTube video seems to increase from ~100% combined (gfx.webrender.force-disabled) to ~160% combined (gfx.webrender.software) here.

PS: I wonder if this is due to duplication of work in both Renderer and SWCompositor.

Fedora uses WebRender with KWin/Wayland already so no objections here. IMHO wayland compositor type is not as important as driver/mesa versions.

Flags: needinfo?(stransky)

(In reply to Jan Alexander Steffens [:heftig] from comment #3)

Open question: should we fall back to SW-WR instead of basic already if HW-WR fails?

In an impromptu test, the total CPU usage for playing a YouTube video seems to increase from ~100% combined (gfx.webrender.force-disabled) to ~160% combined (gfx.webrender.software) here.

PS: I wonder if this is due to duplication of work in both Renderer and SWCompositor.

Getting SW-WR to perform as good as basic is AFAIK not a design goal per-se. IIUC one major motivation is that having only WR unlocks a bunch of possible optimizations (e.g. dropping display lists and much of the associated costs) - see for example bug 1701437 comment 2.

So slightly less performance in SW-WR should probably not be a blocker, as long as it's not too bad and the stability doesn't suffer.

This effectively enables WR on Weston, Sway and KWin-Wayland -
unlike on X11, few issues appear to be related to WR.

Assignee: nobody → robert.mader
Status: NEW → ASSIGNED

+1. For what it's worth, in Plasma/Wayland, Firefox works better with WR than with BR.

Flags: needinfo?(vlad.zahorodnii)

This was tracked in bug 1587060 already

Alias: wr-wayland
Blocks: wr-linux-wayland
No longer blocks: wayland
Summary: [wayland] Enable Webrender on all compositors → [wayland] Enable Webrender on all compositors on Mesa Intel/AMD
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/1f7d7c5d90ef
Enable WR on Intel/AMD on Wayland, r=aosmond
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Flags: needinfo?(aosmond)
You need to log in before you can comment on or make changes to this bug.