Closed Bug 1702155 Opened 8 months ago Closed 7 months ago

[Intermittent] Address bar chiclet is missing from about: pages after browser restart

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 89
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- affected

People

(Reporter: phorea, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-address-bar])

Attachments

(1 file)

Attached image missingClichet.png

[Note]:

  • This issue is intermittent and at this point we don't know what triggers it
  • This issue doesn't occur on OSX 11.2.3

[Affected versions]:

  • latest Nightly 89.0a1 2021-03-30

[Affected platforms]:

  • Win 10 64-bit
  • Ubuntu 18.04

[Preconditions]:
The following prefs are enabled in about:config:

  • browser.proton.enabled
  • browser.proton.toolbar.enabled
  • browser.proton.urlbar.enabled

[Steps to reproduce]:

  1. Go to about:preferences and check the option to "Restore previous session"
  2. Open a few about: pages and observe the address bar chiclet
  3. Restart the browser

[Expected result]:

  • Address bar chiclet stays the same after restart

[Actual result]:

  • Address bar chiclet is replaced by the magnifying glass, the page needs to be refreshed for it to be shown again

[Regression range]:

  • Due to the fact that the issue is intermittent we can't provide a regression range at this point.

[Additional notes]:

  • There are no errors in browser console
Priority: -- → P3

I managed to reproduce this as well, on about:support.
One thing to note is that initially the chiclet appears but is quickly replaced by the magnifying glass icon.

It looks like more a focus problem. Considered we only changed the styling here I think it's not a Proton regression.

Flags: needinfo?(itiel_yn8)
Flags: needinfo?(itiel_yn8)

I haven't encountered this on Firefox 89 beta 1 to 11, so I'm closing as RWFM for now.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.