Sourcecode in viewer is shown as uncommented but shown in browser as commented

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
15 years ago
4 years ago

People

(Reporter: Daniel de Wildt, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
The internal source viewer shows the source code as uncommented when a second
closed comment comes after a non closed first comment. The browser handles the
uncommented source as commented.
Either the source viewer should show the code as commented or the browser should
parse it.

I think this bug depends on bug 170276.
First it must be clearly defined what's the correct result.
Is the source code commented or uncommented ?

Comment 1

15 years ago
sgml clearly defines what should happen.
Assignee: doron → harishd
Component: ViewSource → Parser
QA Contact: pmac → moied
Probably one of the bug 57724 cluster. View-source passes through the 
HTML tokenizer right now to do syntax coloring when it should probably 
have its own tokenizer, but that's not really a good job to tackle with 
harishd moving away from full-time parser work.
This is a dup in any case (of the "view source always parses comments in quirks
mode" bug).
Whiteboard: DUPEME
(Reporter)

Comment 4

15 years ago
No, I think this isn't a dup of bug 57724, because the source looks correct in
the viewer. The code is (nearly) identical with the code I viewed in IE and in
"sam spade" and the first comment is really not closed.

Sorry for my inexperience when Mozilla shows the comment correct.
(In that case the page is rendered wrong.)
OK.  I looked at the actual site.  It's in quirks mode.  The comment is
correctly parsed per quirks mode.  The site does not show up for a totally
unrelated reason (unclosed <title> tag).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

15 years ago
Yes, that's the bug.
Next time I will verify the correctness of the source code before filing a bug.

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.