Domain Guessing: unusable

VERIFIED DUPLICATE of bug 115539

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 115539
15 years ago
14 years ago

People

(Reporter: Neil J. McLeish, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.1) Gecko/20020826

I have an internal URL http://lxdev/bblink.html for testing sites internal to my
LAN.
I have set the URL as a link.
Whenever I try to access it, the autocomplete makes it
http://www.lxdev.com/bblink.html.
I cannot see a simple way to stop this behaviour.

Reproducible: Always

Steps to Reproduce:
1.See 'Details'
2.
3.

Actual Results:  
See Details

Expected Results:  
Mozilla should have done nothing to the URL, especially as 'lxdev' is set as a
URL for which the proxy should be ignored.



In terms of usability, this seems to be a default behaviour.
Behaviours such as this should be switched off by default.

This looks like a classic case of trying to anticipate the average user's wishes.

There is no such thing as an 'average' user.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 147119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
REOPEN: Lets get a full problem description first.
Are you using a proxy w/ a "no proxy" config? You made a comment that suggests that.

Also, if you type "nslookup lxdev", does that resolve?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This is probably fixup, not autocomplete
Assignee: hewitt → adamlock
(Assignee)

Comment 4

15 years ago
Duping against 115539. There is a pref to disable this fixup (which will only be
triggered if the host address could not be found) but no UI. See the patch in
the bug for the pref value.

*** This bug has been marked as a duplicate of 115539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
I'm still wanting more user information. If there is a proxy, the fixup is not
local, it occurs because of the proxy server response (many proxies emulate our
fixup behavior with a redirect when they have a DNS hostname lookup error).

Comment 6

14 years ago
V:
Domain Guessing may have happened because DNS was configured wrong causing
hostname "lxdev" not to be found -or- DG had a phase were it pre-emptively
mapped "hostname" -> "wwww.hostname.com" (see bug 147119).
Status: RESOLVED → VERIFIED
QA Contact: claudius → benc
Summary: Autocomplete unusable → Domain Guessing: unusable

Updated

14 years ago
Component: Location Bar → Embedding: Docshell
You need to log in before you can comment on or make changes to this bug.