Closed Bug 1703150 Opened 6 months ago Closed 3 months ago

The Developer Tools panel includes the "Customize Toolbar" option from the More Tools content in the AppMenu when Proton is enabled

Categories

(Firefox :: Menus, defect, P2)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- verified

People

(Reporter: tduzan, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers][priority:2b])

Attachments

(1 file)

We changed the AppMenu in MR1 to surface the developer tools more prominently just one step down from the main menu under "More Tools". We also moved the "Customize Toolbar" option there at the top above a divider. While doing my PM review for MR1, I noticed that opening the Developer Tools from the toolbar icon would show "Customize Toolbar" at the top even though is not part of the developer tools.

The content for this panel and the "More Tools" section of the AppMenu should differ, as this panel should /only/ show developer tools.

Priority: -- → P2
Whiteboard: [proton-door-hangers][priority:2b]
Severity: -- → S2
Duplicate of this bug: 1707299

Any chance you will be able to reconsider bug 1695517 if the content for developer toolbar button and "More Tools" in AppMenu will be separated anyway?

Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2aa230271ab3
ensure dev tools subview is shown when opening developer tools panel r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+

Hi Emma! I've tried to verify this fix on latest Beta 91.0b9, but I cannot seem to understand what was the patch about. I can still see the "Customize toolbar..." option in AppMenu -> More tools panel. Also, the panels looks the same on the latest builds, compared to an affected one (Nightly from 2021-04-05).

Can you please let me know what should we verify here?

Flags: needinfo?(emalysz)

Hi Ciprian, "Customize toolbar" should still be available in the more tools menu from the app menu. To reproduce this error, add the "developer tools" toolbarbutton and examine that menu. This menu should no longer contain "Customize toolbar"

Flags: needinfo?(emalysz)

Thanks, Emma! I can confirm that the "Customize Toolbar" option is not displayed anymore in toolbar button's panel, on RC1 91.0. Tested under macOS 11, Ubuntu 21.04 x64 and Win 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.