Closed Bug 1703411 Opened 8 months ago Closed 8 months ago

toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js failing after Find bar styling changes

Categories

(Toolkit :: Find Toolbar, defect)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- fixed

People

(Reporter: Gijs, Assigned: jaws)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-infobars])

Attachments

(1 file)

[task 2021-04-06T21:36:04.584Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element left border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 83
[task 2021-04-06T21:36:04.585Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.585Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:83
[task 2021-04-06T21:36:04.586Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:109
[task 2021-04-06T21:36:04.587Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.588Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element right border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 88
[task 2021-04-06T21:36:04.589Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.589Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:88
[task 2021-04-06T21:36:04.590Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:109
[task 2021-04-06T21:36:04.591Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.592Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element top border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 93
[task 2021-04-06T21:36:04.592Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.593Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:93
[task 2021-04-06T21:36:04.593Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:109
[task 2021-04-06T21:36:04.594Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.594Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element bottom border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 98
[task 2021-04-06T21:36:04.595Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.595Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:98
[task 2021-04-06T21:36:04.596Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:109
[task 2021-04-06T21:36:04.600Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.601Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element left border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 83
[task 2021-04-06T21:36:04.602Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.603Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:83
[task 2021-04-06T21:36:04.603Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:110
[task 2021-04-06T21:36:04.604Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.605Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element right border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 88
[task 2021-04-06T21:36:04.606Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.606Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:88
[task 2021-04-06T21:36:04.607Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:110
[task 2021-04-06T21:36:04.608Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.609Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element top border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 93
[task 2021-04-06T21:36:04.610Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.611Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:93
[task 2021-04-06T21:36:04.611Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:110
[task 2021-04-06T21:36:04.612Z] 21:36:04     INFO - Not taking screenshot here: see the one that was previously logged
[task 2021-04-06T21:36:04.613Z] 21:36:04     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js | Element bottom border color should be set. - "rgb(139, 142, 143)" == "rgb(255, 255, 255)" - JS frame :: chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js :: testBorderColor :: line 98
[task 2021-04-06T21:36:04.613Z] 21:36:04     INFO - Stack trace:
[task 2021-04-06T21:36:04.614Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/head.js:testBorderColor:98
[task 2021-04-06T21:36:04.615Z] 21:36:04     INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js:test_support_toolbar_field_properties_on_findbar:110
[task 2021-04-06T21:36:04.615Z] 21:36:04     INFO - Leaving test bound test_support_toolbar_field_properties_on_findbar

Looks like this probably broke with bug 1702350. This is a blocker for turning on the proton pref. :ntim, can you take a look as you wrote and landed the regressing patch?

Duplicate of this bug: 1703412
Regressed by: 1690334
No longer regressed by: 1702350

Haven't checked, but wrapping these:
https://searchfox.org/mozilla-central/rev/be413c29deeb86be6cdac22445e0d0b035cb9e04/toolkit/components/extensions/test/browser/browser_ext_themes_findbar.js#88-91,109-110

in a if (!gProton) { check should be enough, the border-color prop shouldn't be applied with Proton on the prev/next buttons.

Set release status flags based on info from the regressing bug 1690334

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a5049f34129e
Update browser_ext_themes_findbar.js to check that prev/next border colors are unchanged when a theme is applied if Proton is enabled. r=Gijs
Whiteboard: [proton-infobars]
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.