Closed Bug 1703490 Opened 2 years ago Closed 1 year ago

[Wayland] Remove duplicate D&D handlers

Categories

(Core :: Widget: Gtk, task)

task

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox89 --- wontfix
firefox90 --- wontfix

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

We use duplicated D&D Wayland handlers, let's use the Gtk ones only.

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/003fab04d7cc
[Wayland] Remove duplicate Drag&Drop handlers, r=rmader
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
See Also: → 1622107

Can you please revert this bug to fix caused regression? (Bug 1704287).
Thanks.

Flags: needinfo?(sheriffs)

Backed out changeset 003fab04d7cc (bug 1703490) for causing Bug 1704287

Backout link

Martin: Please request a backout (similar to approval-mozilla-beta? request, copy the template from a different bug if needed) and needinfo :pascalc to get it reverted on beta.

Status: RESOLVED → REOPENED
Flags: needinfo?(sheriffs) → needinfo?(stransky)
Resolution: FIXED → ---

Beta backout Approval Request

User impact if declined: Broken Drag and Drop operations on Wayland (due to Mutter compositor bugs).
Is this code covered by automated tests?: No
Has the fix been verified in Nightly?: Yes
Needs manual test from QE?: No
List of other uplifts needed: None
Risk to taking this patch: Low
Why is the change risky/not risky? (and alternatives if risky): We're reverting to know working state at Firefox 88.

Flags: needinfo?(stransky) → needinfo?(pascalc)
Attachment #9214041 - Attachment is obsolete: true

Thanks, let's close it.

Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → WONTFIX

AFAICT this was never backed out from m-c. Given comment 9, it sounds like we should?

Flags: needinfo?(stransky)
Target Milestone: 89 Branch → ---

Ah yeah, missed that. Thanks.

Flags: needinfo?(stransky)
You need to log in before you can comment on or make changes to this bug.