Closed Bug 1703539 Opened 8 months ago Closed 8 months ago

First unselected tab after tab strip scroll button exceeded the frame and a line separator is displayed

Categories

(Firefox :: Tabbed Browser, defect, P2)

Firefox 89
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- affected

People

(Reporter: hani.yacoub, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-tabs-bar] [priority:2a])

Attachments

(1 file)

Preconditions

In about:config set:
browser.proton.enabled = true

Affected versions

Firefox 89.0a1

Affected platforms

Windows 10 x64
Windows 7 x64
macOS 10.15
Ubuntu 20.04

Steps to reproduce

  1. Open Firefox.
  2. Open many tabs till tab strip scroll buttons appear.
  3. observe the first unselected tab after or before any of the scroll buttons.

Expected result

  • A line is separating the first unselected tab from the strip scroll button.
  • First letter from the first unselected tab exceeded the frame.

Actual Result

  • The line shouldn't be displayed which separates the first unselected tab from the strip scroll button.
  • First letter from the first unselected tab shouldn't exceeded the frame.
Priority: -- → P2
Whiteboard: [proton-tabs-bar] → [proton-tabs-bar] [priority:2a]

This line is necessary in the Dark theme where otherwise the shadow is not visible. Note that in the Light theme there is a visible shadow at the edge of the scrollbuttons when they are clickable.

I recommend this bug should get closed as invalid. This behavior is by design.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.