Closed Bug 1703791 Opened 8 months ago Closed 7 months ago

Proton: Stop flashing the mute status of tabs when the mouse is over the tab bar

Categories

(Firefox :: Tabbed Browser, defect)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: bj, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, nightly-community, Whiteboard: [proton-tabs-bar] [proton-uplift])

Attachments

(1 file)

Visual changes should indicate a state change or an action that needs to be taken. The browser should not be distracting users from their current task.

Steps to reproduce:

  1. Create more than one tab with at least one muted.
  2. Move the pointer over the tab bar.

Expected result:
2) The item pointed to indicates you are pointing to it, and nothing else changes.

Actual result:
2) Items flash that are not being pointed to, distracting attention from the pointed item and the planned action.

I use the Auto Mute add-on so tabs won't distract me with sound, and with the current Proton behavior I have frequent distracting visual flashes when my pointer hits the tab bar.

Dao, could you set a priority for this bug? Thanks

Flags: needinfo?(dao+bmo)
Flags: needinfo?(dao+bmo) → needinfo?(jaws)

It's also simply the audible indicator, not only the muted state.

STR:

  • Have a tab that plays audio, but also other tabs
  • Hover the tab strip

Expected:

  • Only the tab on which the cursor is changes

Actual:

  • The tab on which the cursor changes is highlighted
  • Any tab that is playing audio shows the "audible/muted" icon instead of the favicon, forcing the user to have a look at the playing tab, thinking it must need immediate attention: matrix/slack notification, new email, etc. use this method, it's fairly universal and we shouldn't tamper with it.

This was one of the options that we considered. Aaron, what do you think about changing the behavior here to only change the favicon -> audio icon when hovering the tab instead of the tabstrip?

Flags: needinfo?(jaws) → needinfo?(abenson)

I would argue that this has already become a type of mystery meat navigation: https://en.wikipedia.org/wiki/Mystery_meat_navigation which conceals relevant information until users hover over the area where functionality will be eventually exposed. My feeling is that implementing the expected behavior in comment 2 would make bug 1701443 even worse, because the compact UI doesn't show a textual representation of the muted status like normal density does.

I talked with Aaron and he gave the OK to change it to just the hovered tab. Would someone like to put together the patch? I'm a bit under the weather today.

You can get the relevant bits from https://searchfox.org/mozilla-central/rev/4d45674d062147e19fb1c20fb6eb82fedbeb8079/browser/themes/shared/tabs.inc.css#400-402 which had this feature but was removed. You want to use that to replace https://searchfox.org/mozilla-central/rev/759872688df15a5d6ab305ffe39d90450590bfec/browser/themes/shared/tabs.inc.css#402-406

Flags: needinfo?(abenson)

I 100% agree with Asif Youssuff (comment 4). This is especially annoying for "compact" mode users, because information about currently-playing tab is not visible until you hover.

Additionally, I've already accidentally muted an actively playing tab twice (in two hours of using the new design), because I tried to focus a tab by clicking on its favicon, not paying attention its purpose/action changed after I hovered.

It is hard for me not to compare this behavior to those crosses on web ads that move after you hover them. I admire your, Mozilla, and every one contributor behind Firefox's work, but this is a really bad UX. Respectfully, please change this. 🙏

Severity: -- → S3
Whiteboard: [proton-tabs-bar]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9eef6572db5d
Change the tab audio hover behavior to tab-only based on UX feedback. r=desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

With today's build Compact Mode never shows the favicon for sites, I only get the "muted" icon. Is this intentional?

All my tabs are muted and I want to see the favocon.

(In reply to B.J. Herbison from comment #10)

With today's build Compact Mode never shows the favicon for sites, I only get the "muted" icon. Is this intentional?

All my tabs are muted and I want to see the favocon.

If all of your tabs are muted, then yes none of your favicons would be visible. In compact mode we don't show the second level of text but we do want to have a visible signal that either audio is playing or the tab is muted. This was the trade-off we had to make to keep this level of information visible.

Comment on attachment 9218780 [details]
Bug 1703791 - Change the tab audio hover behavior to tab-only based on UX feedback.

Beta/Release Uplift Approval Request

  • User impact if declined: Required for Proton / MR1
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open two tabs
    Mute one of the tabs
    Mouse over the unmuted tab
    The muted tab should not change it's favicon
    Mouse over the muted tab
    The muted tab should change it's favicon
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change
  • String changes made/needed: none
Attachment #9218780 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Whiteboard: [proton-tabs-bar] → [proton-tabs-bar] [proton-uplift]

Comment on attachment 9218780 [details]
Bug 1703791 - Change the tab audio hover behavior to tab-only based on UX feedback.

Does not look risky, approved for 89 beta 8, thanks.

Attachment #9218780 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: → 1709095
QA Whiteboard: [qa-triaged]

Verified as fixed on Windows 10 x64, macOS 10.15, Ubuntu 20.04 and on Windows 7 x64.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Would it be an option to keep Icon and the control for muting separate at least in the compact theme? This would resolve the concerns raised in https://bugzilla.mozilla.org/show_bug.cgi?id=1703791#c10 .

Expanding on this it probably wouldn't hurt to reconsider combining an icon an a control into the same element regardless of theme. After all, it's confusing with normal and compacted theme alike. Having a separate control seemed like significantly cleaner UI to me, even with the added secondary text of the "normal density" design. The secondary text serves the same purpose the simple icon always did, but it's using up more space and is less functional at the same time.

Flags: needinfo?(jaws)

I don't think I'm the right person to answer this request and unfortunately I'm not sure who to redirect this to. At the moment I don't think we are considering making any changes here.

Flags: needinfo?(jaws)
You need to log in before you can comment on or make changes to this bug.