Closed Bug 1703974 Opened 8 months ago Closed 8 months ago

Lazily create tab-notification-deck

Categories

(Firefox :: Messaging System, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1704868

People

(Reporter: mstriemer, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-infobars])

The tab notification deck isn't needed until we show a notification. However it is created when browser.getNotificationBox() is called which happens in onLocationChange in browser.js [1]. This means that we create the deck quite early even though we don't need it.

This code could instead use browser.readNotificationBox() [2] and only remove transient notifications is the notification box already exists.

A test was removed [3] to allow proton infobars to graduate, something similar should be added back and it should also check that we don't create the deck when navigating.

This is a low-severity performance change that I don't think should not block shipping proton.

[1] https://searchfox.org/mozilla-central/rev/3a798ef9252896fb389679f06dd3203169565af0/browser/base/content/browser.js#5900
[2] https://searchfox.org/mozilla-central/rev/3a798ef9252896fb389679f06dd3203169565af0/browser/base/content/tabbrowser.js#847
[3] https://phabricator.services.mozilla.com/D111310

Priority: -- → P3

This was fixed by bug 1704868

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1704868
You need to log in before you can comment on or make changes to this bug.