Closed Bug 1704071 Opened 8 months ago Closed 8 months ago

Improve the address bar /search bar elements contrast during toolbar customization

Categories

(Firefox :: Toolbars and Customization, enhancement, P2)

Firefox 89
Desktop
Windows 10
enhancement

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: aflorinescu, Assigned: mak)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-address-bar] [priority:2c])

Attachments

(3 files)

[Description:]

This is especially an issue on Windows and dark theme(mac looks better). The contrast, border and shading makes the address bar / search bar customization not a great experience. I'd argue that for the purpose of customization, we'd prefer an element that focuses more on the visibility rathher than 1 to 1 match to the actual element.

[Note:]
  1. This is not really a regression, non-proton 87 version has similar address bar element. However, 87 version has the search bar much better contrasted - maybe border/shading?
[Steps:]
  1. Open Firefox
  2. Open Customize Toolbar.
  3. Drag and drop addressbar/searchbar element
Component: Address Bar → Toolbars and Customization
Attached image search.png

This is on, on Win10 I get the exact same colors on both.

Priority: -- → P2
Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2c]

(In reply to Romain Testard [:RT] from comment #1)

Created attachment 9215135 [details]
search.png

This is on, on Win10 I get the exact same colors on both.

That screenshot is from normal use; this bug is about how the search bar and url bar look in customize mode, when dragging them.

we could probably add some borders here

Summary: Improve the address bar /search bar elements contrast (toolbar customization) → Improve the address bar /search bar elements contrast during toolbar customization
Assignee: nobody → mak
Status: NEW → ASSIGNED

To improve the visibility of these input fields this pathc adds a border based
on currentColor and reuse the urlbar shadow. This is a small improvement over the
status-quo, the applied transparencies are controlled by the drag'n'drop code.
This issue exists also in pre-proton, so the styles apply regardless.

The landing patch should improve the situation but it won't completely solve it, because we have no control over the translucency drawn by the OS. We can re-evaluate once platform adds support for controlling the image.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/e76fec22745d
Increase address bar and search bar contrast during toolbar customization. r=harry
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

(In reply to Marco Bonardo [:mak] from comment #5)

The landing patch should improve the situation but it won't completely solve it, because we have no control over the translucency drawn by the OS. We can re-evaluate once platform adds support for controlling the image.

It looks indeed better on latest Firefox 89 beta 4. Should we file a follow-up for the remaining work? Thank you!

Status: RESOLVED → VERIFIED
Flags: needinfo?(mak)

(In reply to Petruta Horea [:phorea] from comment #8)

It looks indeed better on latest Firefox 89 beta 4. Should we file a follow-up for the remaining work? Thank you!

There is already some work tracked in bug 1683376 to be able to control the traslucency, and until that is done we can't really do anything.

Flags: needinfo?(mak)
You need to log in before you can comment on or make changes to this bug.