Closed Bug 1704273 Opened 5 months ago Closed 5 months ago

egyptian hieroglyphs are not displayed anymore since last update

Categories

(Core :: Layout: Text and Fonts, defect, P2)

Firefox 87
Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- fixed

People

(Reporter: paris, Assigned: jfkthame)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

i updated firefox

Actual results:

Egyptian Hieroglyphs are not displayed afterwards

Expected results:

Egyptian Hieroglyphs should still be display as before

Summary: 600198 seems to be a problem again, since it definitely worked in 2020 → egyptian hieroglyphs are not displayed anymore since last update

with the last update firefox can not display egyptian hieroglyphs anymore.

check here:

http://www.alanwood.net/unicode/egyptian-hieroglyphs.html

it worked fine with older versions before 87.

Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core

It works for me on macOS 11.0. I think this must be a version-specific issue; there are differences between macOS versions regarding how the installed fonts are handled.

I guess bug 1690877 and/or bug 1691719 may be the culprit here. Some experimentation will be needed to pin down exactly what's wrong...

screen of system info with Firefox version 86 and 87 with 𓆏 (U+1318F) to make the problem visible

I'm fairly sure this must be a regression from bug 1690877; hoping to confirm this shortly. It affects macOS 10.13 but not 11.0; it would be helpful to know about intermediate versions so that we can target a fix correctly. I'll see if we can get help from QA to confirm exactly what versions are affected.

Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → macOS
Priority: -- → P2
Regressed by: 1690877
Keywords: regression

macOS 10.15 is OK

I can confirm that this issue is reproducible on: macOS 10.13 & 10.14.

This issue is not reproducible on: macOS 10.15 & 11.3

Thanks Emil - really appreciate your help here.

Assignee: nobody → jfkthame
Status: NEW → ASSIGNED

Set release status flags based on info from the regressing bug 1690877

Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf68997c9112
Activate supplemental fonts in all processes on older versions of macOS. r=lsalzman
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
QA Whiteboard: [qa-89b-p2]
You need to log in before you can comment on or make changes to this bug.