SELECT beahves funny when CSS is used

RESOLVED DUPLICATE of bug 154670

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 154670
16 years ago
16 years ago

People

(Reporter: Stewart James, Assigned: John Keiser (jkeiser))

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If you have styles for SELECT like this:

SELECT { background-color: #dfddd5; }
SELECT:focus { background-color: #d6dbd3; }
SELECT:hover { background-color: #c9cec7; }

Pulldown menus bhave oddly. If all three of above are set, pull the pulldown
menu down and when you move your mouse the pull down menu is removed from screen.

If just :focus is used PDM is difficult to pull down - click to focus, click
pulldown instead of just a single click.
(Reporter)

Comment 1

16 years ago
Created attachment 100361 [details]
sample for bug

You get ddiffereing results depending on which of the select style's you leave
enabled. once :foxu or :hover are in play none the select pull down items
behave strangely. This worked fine in mozilla 1.0 and netscape7, but not
mozilla 1.1 or 1.2a

Comment 2

16 years ago
Testcase WFM in build 2002091014 PC/Win98.
Added kw testcase.
Keywords: testcase

Comment 3

16 years ago
dupe of "drop-down select menu closed by DOM events."

*** This bug has been marked as a duplicate of 154670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.