Closed Bug 1704602 Opened 10 months ago Closed 9 months ago

Only about:home respects browser theme

Categories

(Firefox :: Foxfooding, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: j.heavener, Unassigned)

References

Details

(Whiteboard: [proton-aboutpages] [priority:2b] [foxfooding][internal] [proton-foxfooding])

steps to reproduce/what did you do?

Setup: Firefox Theme set to Light and System Theme set to Dark, 'browser.aboutwelcome.design' set to 'proton'

Visit about:home
Visit another about page, such as about:preferences

expected behavior/ what did you think will happen?

Firefox theme treats about pages consistent with theme:

  • chrome is light, per theme
  • about:home is light, per theme
  • about:preferences is light, per theme

OR, Firefox styles only the chrome, leaves about pages to respect prefers-color-scheme:

  • chrome is light, per theme
  • about:home is dark, per system
  • about:preferences is dark, per system

actual behavior/ what actually happened?

  • Chrome is light, per theme
  • about:home is light, per theme
  • about:preferences is dark, per system

Looks like about:home is using the FF theme, ignoring prefers-color-scheme, but the other about pages are not.

Priority: -- → P2
Whiteboard: [proton-aboutpages] [priority:2b]
Whiteboard: [proton-aboutpages] [priority:2b] → [proton-aboutpages] [priority:2b] [foxfooding]
Whiteboard: [proton-aboutpages] [priority:2b] [foxfooding] → [proton-aboutpages] [priority:2b] [foxfooding][internal] [proton-foxfooding]

Hi Jody, is this still reproducible on Nightly? Bug 1701691 might have fixed this.

See Also: → 1701691

Just checked again and I think this is now resolved. The only page that maybe I would expect to use the theme but doesn't is about:debugging, but it might not fall under theme-able pages. All other pages that I observed not using the theme now use it.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

This was fixed in 89 via bug 1701691.

Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.