Closed Bug 1704618 Opened 8 months ago Closed 8 months ago

Flipping the proton context menu pref at runtime can cause glitchy/broken layout of Windows context menus until the next restart

Categories

(Firefox :: Untriaged, defect)

Desktop
Windows 10
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: andro.marian.v94, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36

Steps to reproduce:

I just disable the browser.proton.contextmenus.enabled

Actual results:

The old context menu is broken: missing corners, border
The top icons are not correctly aligned.

Expected results:

To be exactly like the old one

Attached image Untitled.png

The Bugbug bot thinks this bug is invalid.
If you think the bot is wrong, please reopen the bug and move it back to its prior component.

Be aware this is a production bug database used by the Mozilla community to develop Firefox, and other products.
Filing test bugs here wastes the time of all our contributors, volunteers, as well as paid employees.
If you continue to abuse bugzilla.mozilla.org your account will be disabled.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Component: Untriaged → General
Product: Firefox → Invalid Bugs
Resolution: --- → INVALID
Version: Firefox 89 → unspecified
Status: RESOLVED → REOPENED
Component: General → Untriaged
Ever confirmed: true
Product: Invalid Bugs → Firefox
Resolution: INVALID → ---
Whiteboard: [proton-context-menus]
Attached image WFM

I can't reproduce.

Can you check a clean profile and provide complete steps?

Flags: needinfo?(andro.marian.v94)
Flags: needinfo?(andro.marian.v94)

(In reply to Andronachi Marian from comment #4)

https://www.youtube.com/watch?v=w_WqZ_B1cPk

So I'm confused... it reproduces some of the time for you? I can't work out from the video what is different between the times it reproduces and doesn't reproduce.

In general, I have seen some artifacts after changing the pref at runtime. But when you experienced the glitchy menu immediately after flipping the pref, AFAICT in the video you never just restarted the browser (without either running Firefox refresh/reset, or removing the profile folder). When this does reproduce, does restarting the browser make the issue go away?

Flags: needinfo?(andro.marian.v94)

Yea. Seams to work only if I restart the browser in both cases.

  1. If I toggle the setting to false. The old context menu is bugged.
    After I restart the browser, the old one is ok.
  2. If I toggle the setting to true. The new context menu is bugged.
    After I restart the browser, the new one is ok.
Flags: needinfo?(andro.marian.v94)
  1. If the setting is false after restart, toggle to true.
    The new one is bugged, but after toggle it to false again, the old one is bugged too.

OK. We don't really intend to turn this on/off at runtime for users, or support frequently flipping backwards and forwards (not sure there'd be a reason to do that?), and browser restarts are pretty easy to do so, I don't think we'll spend time investigating and fixing this as we have too many other more serious issues to focus on.

Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Resolution: --- → WONTFIX
Summary: Proton design break the old context menu → Flipping the proton context menu pref at runtime can cause glitchy/broken layout of Windows context menus until the next restart
You need to log in before you can comment on or make changes to this bug.