Closed Bug 1704752 Opened 8 months ago Closed 8 months ago

Poor contrast for the "Always open in a container" icon on default theme

Categories

(Firefox :: Address Bar, defect)

Unspecified
Linux
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-address-bar])

Attachments

(2 files)

Attached image Screenshot

Other icons are white, but this one doesn't seem to be. If I switch to the dark theme then it works as I'd expect.

So what makes it work in the dark theme is bug 1702034... Probably that should be applied for system dark theme too?

Depends on: 1702034
Assignee: nobody → emilio
Status: NEW → ASSIGNED

Hm, for some reason I cannot reproduce that, I'm on Windows 10 set on Dark and theme set to "System Theme".

Whiteboard: [proton-address-bar]

That's because the "system theme" in dark mode on Windows and Mac is really just the dark theme.

Is this on Linux? Ok, that makes sense.

OS: Unspecified → Linux
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e2908236059
Apply the workaround from bug 1702034 to the default theme if it's dark as well. r=mak
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

verified fix on windows10 64bit and Ubuntu 20 and mac0S 10.15 with OS theme set as dark and Fx set as system theme.

Release 89.0.2
Beta 90.0b12
Nightly 91.0a1

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.